lkml.org 
[lkml]   [2024]   [May]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [git pull] drm for 6.10-rc1
On Thu, 16 May 2024 at 06:43, Linus Torvalds
<torvalds@linux-foundation.org> wrote:
>
> On Tue, 14 May 2024 at 23:21, Dave Airlie <airlied@gmail.com> wrote:
> >
> > This is the main pull request for the drm subsystems for 6.10.
>
> .. and now that I look more at this pull request, I find other things wrong.
>
> Why is the DRM code asking if I want to enable -Werror? I have Werror
> enabled *already*.
>
> I hate stupid config questions. They only confuse users.
>
> If the global WERROR config is enabled, then the DRM config certainly
> shouldn't ask whether you want even more -Werror. It does nothing but
> annoy people.
>
> And no, we are not going to have subsystems that can *weaken* the
> existing CONFIG_WERROR. Happily, that doesn't seem to be what the DRM
> code wants to do, it just wants to add -Werror, but as mentioned, its'
> crazy to do that when we already have it globally enabled.
>
> Now, it might make more sense to ask if you want -Wextra. A lot of
> those warnings are bogus.

The help says:

The drm subsystem enables more warnings than the kernel default, so
this config option is disabled by default.

It's also

depends on DRM && EXPERT

so we aren't throwing it at random users.

should we rename it CONFIG_DRM_WERROR_MORE or something?

Dave.

\
 
 \ /
  Last update: 2024-05-16 00:45    [W:0.084 / U:1.004 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site