lkml.org 
[lkml]   [2024]   [Apr]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v18 2/9] usb: dwc3: core: Access XHCI address space temporarily to read port info
From


On 4/3/2024 12:36 PM, Johan Hovold wrote:
> On Wed, Apr 03, 2024 at 10:54:25AM +0530, Krishna Kurapati PSSNV wrote:
>
>>>> +static int dwc3_read_port_info(struct dwc3 *dwc)
>>>> +{
>>>> + void __iomem *base;
>>>> + u8 major_revision;
>>>> + u32 offset;
>>>> + u32 val;
>>>> +
>>>> + /*
>>>> + * Remap xHCI address space to access XHCI ext cap regs since it is
>>>> + * needed to get information on number of ports present.
>>>> + */
>>>> + base = ioremap(dwc->xhci_resources[0].start,
>>>> + resource_size(&dwc->xhci_resources[0]));
>>>> + if (IS_ERR(base))
>>>> + return PTR_ERR(base);
>>>
>>> Looks like you forgot to address some of the comments you said you'd
>>> update previously if you submit a new version to the series.
>>>
>>> [*] https://lore.kernel.org/linux-usb/af73110d-e13e-4183-af11-aed869ac0a31@quicinc.com/
>>>
>>
>> Apologies. I agree. I was too much focused on acpi removal and interrupt
>> cleanup, I forgot the last comment you gave.
>>
>> Can I send in a separate patch for this ?
>
> The series has not been merged yet so you can address both issues in a
> v19. Perhaps wait a day or two in case Thinh has further comments.
>

Sure Johan.

Also after making the following two changes:

1. Rename dwc3_read_port_info(...) to dwc3_get_num_ports(...)
2. Changing "if (IS_ERR(base))" to "if (!base)"

Can I still retain your RB tag ?

Regards,
Krishna,

\
 
 \ /
  Last update: 2024-05-27 16:20    [W:0.038 / U:0.028 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site