lkml.org 
[lkml]   [2024]   [Mar]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v19 001/130] x86/virt/tdx: Rename _offset to _member for TD_SYSINFO_MAP() macro
Date
On Fri, 2024-03-08 at 15:25 +0800, Binbin Wu wrote:
>
> On 2/26/2024 4:25 PM, isaku.yamahata@intel.com wrote:
> > From: Kai Huang <kai.huang@intel.com>
> >
> > TD_SYSINFO_MAP() macro actually takes the member of the 'struct
> > tdx_tdmr_sysinfo' as the second argument and uses the offsetof() to
> > calculate the offset for that member.
> >
> > Rename the macro argument _offset to _member to reflect this.
> >
> > Signed-off-by: Kai Huang <kai.huang@intel.com>
> > Reviewed-by: Kirill A. Shutemov <kirill.shutemov@linux.intel.com>
> > Signed-off-by: Isaku Yamahata <isaku.yamahata@intel.com>
>
> Reviewed-by: Binbin Wu <binbin.wu@linux.intel.com>
>
>

Thanks for review.

I've sent out the first 5 metadata read patches as a standalone patchset
separately:

https://lore.kernel.org/kvm/cover.1709288433.git.kai.huang@intel.com/

I'll add your Reviewed-by in next version.

(for others please comment there instead, thanks!)
\
 
 \ /
  Last update: 2024-05-27 15:41    [W:0.291 / U:0.136 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site