lkml.org 
[lkml]   [2024]   [Mar]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: [PATCH V4 00/10] mm: page_alloc: freelist migratetype hygiene
    Date
    On 27 Mar 2024, at 5:30, Vlastimil Babka wrote:

    > On 3/20/24 7:02 PM, Johannes Weiner wrote:
    >> V4:
    >> - fixed !pcp_order_allowed() case in free_unref_folios()
    >> - reworded the patch 0 changelog a bit for the git log
    >> - rebased to mm-everything-2024-03-19-23-01
    >> - runtime-tested again with various CONFIG_DEBUG_FOOs enabled
    >>
    >> ---
    >>
    >> The page allocator's mobility grouping is intended to keep unmovable
    >> pages separate from reclaimable/compactable ones to allow on-demand
    >> defragmentation for higher-order allocations and huge pages.
    >>
    >> Currently, there are several places where accidental type mixing
    >> occurs: an allocation asks for a page of a certain migratetype and
    >> receives another. This ruins pageblocks for compaction, which in turn
    >> makes allocating huge pages more expensive and less reliable.
    >>
    >> The series addresses those causes. The last patch adds type checks on
    >> all freelist movements to prevent new violations being introduced.
    >>
    >> The benefits can be seen in a mixed workload that stresses the machine
    >> with a memcache-type workload and a kernel build job while
    >> periodically attempting to allocate batches of THP. The following data
    >> is aggregated over 50 consecutive defconfig builds:
    >
    > Great stuff. What would you say to the following on top?
    >
    > ----8<----
    > From 84f8a6d3a9e34c7ed8b438c3152d56e359a4ffb4 Mon Sep 17 00:00:00 2001
    > From: Vlastimil Babka <vbabka@suse.cz>
    > Date: Wed, 27 Mar 2024 10:19:47 +0100
    > Subject: [PATCH] mm: page_alloc: change move_freepages() to
    > __move_freepages_block()
    >
    > The function is now supposed to be called only on a single pageblock and
    > checks start_pfn and end_pfn accordingly. Rename it to make this more
    > obvious and drop the end_pfn parameter which can be determined trivially
    > and none of the callers use it for anything else.
    >
    > Also make the (now internal) end_pfn exclusive, which is more common.
    >
    > Signed-off-by: Vlastimil Babka <vbabka@suse.cz>
    > ---
    > mm/page_alloc.c | 43 ++++++++++++++++++++-----------------------
    > 1 file changed, 20 insertions(+), 23 deletions(-)
    >
    This looks good to me and makes sense. Reviewed-by: Zi Yan <ziy@nvidia.com>

    --
    Best Regards,
    Yan, Zi
    [unhandled content-type:application/pgp-signature]
    \
     
     \ /
      Last update: 2024-05-27 16:12    [W:4.130 / U:0.028 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site