lkml.org 
[lkml]   [2024]   [Mar]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: [PATCH rdma-next 4/4] RDMA/mana_ib: Use struct mana_ib_queue for RAW QPs
Date
> From: Long Li <longli@microsoft.com>
> Sent: Friday, 15 March 2024 18:04
> To: Konstantin Taranov <kotaranov@linux.microsoft.com>; Konstantin
> Taranov <kotaranov@microsoft.com>; sharmaajay@microsoft.com;
> jgg@ziepe.ca; leon@kernel.org
> Cc: linux-rdma@vger.kernel.org; linux-kernel@vger.kernel.org
> Subject: RE: [PATCH rdma-next 4/4] RDMA/mana_ib: Use struct
> mana_ib_queue for RAW QPs
>
> > +struct mana_ib_raw_qp {
> > + /* Work queue info */
> > + struct mana_ib_queue queue;
> > + mana_handle_t tx_object;
> > +};
> > +
> > struct mana_ib_qp {
> > struct ib_qp ibqp;
> >
> > - /* Work queue info */
> > - struct ib_umem *sq_umem;
> > - int sqe;
> > - u64 sq_gdma_region;
> > - u64 sq_id;
> > - mana_handle_t tx_object;
> > + struct mana_ib_raw_qp sq;
>
> What's the naming scheme for RC? Maybe use raw_sq here?

The plan is to use struct mana_ib_rc_qp for RC QP.
But I think mana_ib_raw_sq is a good proposal for RAW packets. I will make it in v2.
Thanks!

\
 
 \ /
  Last update: 2024-05-27 15:52    [W:4.646 / U:0.192 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site