lkml.org 
[lkml]   [2024]   [Feb]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v10 0/5] Add display support for stm32f769-disco board
From
Hi Dario

On 1/27/24 16:28, Dario Binacchi wrote:
> The series adds display support for the stm32f769-disco board. It has been
> tested on hardware revisions MB1225-B03 and MB1166-A09. This required
> modifications to the nt35510 driver that have already been applied.
>
> Changes in v10:
> - Drop backlight. From a closer analysis of the schematics
> en.MB1225-F769I-B01_Schematic.pdf and en.mb1166-default-a09-schematic.pdf,
> it is noticed that the GPIO I14 is connected to an unmounted
> resistor (n/a), making the backlight functionality via GPIO unusable.
> - Drop backlight references
>
> Changes in v9:
> - Drop 'interrupts' property to fix yaml checks
> - Rename vcc_3v3 to to vcc-3v3
> - Rename panel-dsi@0 to panel@0 to fix yaml warnings
> - Change commit message
> - Rename stm32f769-disco-mb1225-revb03-mb1166-reva09 to
> stm32f769-disco-mb1166-reva09
>
> Changes in v8:
> - Add Acked-by tag of Lee Jones
> - Add Reviewed-by tag of Raphael Gallais-Pou
> - Add Reviewed-by tag of Raphael Gallais-Pou
> - Remove unit name from 'ltdc/port/endpoint@0' to fix the compiling
> warning:
> ../arch/arm/boot/dts/st/stm32f769-disco.dts:189.28-191.5: Warning
> (unit_address_vs_reg): /soc/display-controller@40016800/port/endpoint@0: node
> has a unit name, but no reg or ranges property
> - Add Reviewed-by tag of Linus Walleij
> - Add Reviewed-by tag of Raphael Gallais-Pou
>
> Changes in v7:
> - Replace .dts with .dtb in the Makefile
>
> Changes in v6:
> - Drop patches
> - [5/8] dt-bindings: nt35510: add compatible for FRIDA FRD400B25025-A-CTK
> - [7/8] drm/panel: nt35510: move hardwired parameters to configuration
> - [8/8] drm/panel: nt35510: support FRIDA FRD400B25025-A-CTK
> because applied by the maintainer Linus Walleij
>
> Changes in v5:
> - Replace GPIOD_ASIS with GPIOD_OUT_HIGH in the call to devm_gpiod_get_optional().
>
> Changes in v2:
> - Add Acked-by tag of Conor Dooley
> - Change the status of panel_backlight node to "disabled"
> - Delete backlight property from panel0 node.
> - Re-write the patch [8/8] "drm/panel: nt35510: support FRIDA FRD400B25025-A-CTK"
> in the same style as the original driver.
>
> Dario Binacchi (5):
> dt-bindings: mfd: stm32f7: Add binding definition for DSI
> ARM: dts: stm32: add DSI support on stm32f769
> ARM: dts: stm32: rename mmc_vcard to vcc-3v3 on stm32f769-disco
> ARM: dts: stm32: add display support on stm32f769-disco
> ARM: dts: add stm32f769-disco-mb1166-reva09
>
> arch/arm/boot/dts/st/Makefile | 1 +
> .../dts/st/stm32f769-disco-mb1166-reva09.dts | 13 ++++
> arch/arm/boot/dts/st/stm32f769-disco.dts | 70 +++++++++++++++++--
> arch/arm/boot/dts/st/stm32f769.dtsi | 20 ++++++
> include/dt-bindings/mfd/stm32f7-rcc.h | 1 +
> 5 files changed, 101 insertions(+), 4 deletions(-)
> create mode 100644 arch/arm/boot/dts/st/stm32f769-disco-mb1166-reva09.dts
> create mode 100644 arch/arm/boot/dts/st/stm32f769.dtsi
>

Series applied on stm32-next.

Thanks for your efforts.

Alex



\
 
 \ /
  Last update: 2024-05-27 15:27    [W:0.045 / U:0.188 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site