Messages in this thread |  | | From | Alice Ryhl <> | | Date | Fri, 29 Nov 2024 10:36:30 +0100 | | Subject | Re: [GIT PULL] tracing: More updates for 6.13 |
| |
On Thu, Nov 28, 2024 at 8:55 PM Linus Torvalds <torvalds@linux-foundation.org> wrote: > > On Wed, 27 Nov 2024 at 10:18, Steven Rostedt <rostedt@goodmis.org> wrote: > > > > [ > > NOTE: The rust tracepoint code added hooks to the same macros that were > > modified in this pull request. The merge has non-trivial conflicts. I > > fixed it up in my "for-next" branch in the same repository. That branch > > was a merge of this branch into the commit where you pulled the rust > > tracepoint code. > > I checked my resolution against yours, and I don't think your > resolution is right. > > You didn't check 'cond' on regular rust tracepoints, and you didn't do > any locking on either kind. > > I've pushed out my resolution, and hopefully rust people can actually > test it. I might just be full of it. > > That said, I also think that the "__rust_do_trace_##name" inline > helper should just be renamed to "__trace_##name", and then the > regular trace_##name() helper could use that inside the > static_branch_unlikely() check. Because that seems to be the only real > thing the "rust" version wants - avoiding the static branch > infrastructure in favor of whatever rust infrastructure.
The Rust parts look reasonable to me, thanks!
Alice
|  |