lkml.org 
[lkml]   [2024]   [Jan]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
Subject[PATCH 0/2] mm: zswap: simplify zswap_swapoff()
From
This mini-series simplifies aims to zswap_swapoff(), which should
simplify in progress work touching it (zswap tree split, rbtree to
xarray conversion).

Patch 1 is a code readability change in the core swap code that makes
patch 2 (the actual simplification) more obviously correct.

Yosry Ahmed (2):
mm: swap: update inuse_pages after all cleanups are done
mm: zswap: remove unnecessary tree cleanups in zswap_swapoff()

mm/swapfile.c | 4 ++--
mm/zswap.c | 9 ++-------
2 files changed, 4 insertions(+), 9 deletions(-)

--
2.43.0.429.g432eaa2c6b-goog


\
 
 \ /
  Last update: 2024-01-20 03:40    [W:0.142 / U:0.688 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site