lkml.org 
[lkml]   [2023]   [Jul]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH] serial: qcom-geni: use icc tag defines
From
On 11.07.23 19:05, Johan Hovold wrote:
> Use the Qualcomm interconnect defines rather than magic numbers for the
> icc tags also in the restore() PM callback.
>
> Signed-off-by: Johan Hovold <johan+linaro@kernel.org>

Reviewed-by: Georgi Djakov <djakov@kernel.org>

> ---
> drivers/tty/serial/qcom_geni_serial.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/tty/serial/qcom_geni_serial.c b/drivers/tty/serial/qcom_geni_serial.c
> index 444c74eeab7d..88ed5bbe25a8 100644
> --- a/drivers/tty/serial/qcom_geni_serial.c
> +++ b/drivers/tty/serial/qcom_geni_serial.c
> @@ -1757,7 +1757,7 @@ static int qcom_geni_serial_sys_hib_resume(struct device *dev)
> private_data = uport->private_data;
>
> if (uart_console(uport)) {
> - geni_icc_set_tag(&port->se, 0x7);
> + geni_icc_set_tag(&port->se, QCOM_ICC_TAG_ALWAYS);
> geni_icc_set_bw(&port->se);
> ret = uart_resume_port(private_data->drv, uport);
> /*

\
 
 \ /
  Last update: 2023-07-11 19:01    [W:0.036 / U:0.404 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site