lkml.org 
[lkml]   [2023]   [May]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v11 0/3] regulator: Add X-Powers AXP15060/AXP313a PMIC support
Hi Andre,

Thank you for your work, test succeeded on AXP15060 with no problem.

Tested-by: Shengyu Qu <wiagn233@outlook.com>

Best regards,

Shengyu

> Hi,
>
> this patch series adds support for the X-Powers AXP15060 and AXP313a
> PMIC, which are general purpose PMICs as seen on different boards with
> different SOCs, mostly from Allwinner.
>
> This is mostly a repost of the previous patches, combining both the
> AXP313a and AXP15060 series, rebased on top of v6.4-rc3, and omitting
> the patches that already got merged.
> The first two patches are the successors of the AXP313a v10 post,
> the third patch is based on Shengyu's AXP15060 v3 post.
>
> There were no code changes, just some tiny context differences due to
> the rebase, plus I added the newly gained tags.
>
> As the DT bindings and the AXP15060 MFD part are already in the tree,
> this is just completing support with the MFD part for the AXP313a, and
> the regulator support for both PMICs.
>
> Shengyu, Martin: can you please give this a final test?
>
> Cheers,
> Andre
>
> Changelog:
>
> v3/v10 .. v11:
> - add broonie's and Chen-Yu's review tags
> - rebase on top of v6.4-rc3
>
> AXP313a:
> v9 .. v10:
> - use MFD_CELL_RES macro
> - mark dcdc-freq property as "false" for AXP313a
> - add Lee's ACK
>
> v8 .. v9:
> - use MFD_CELL_NAME macro
> - fix LDO regulator names to match the datasheet
> - only mark changing registers as volatile
> - use correct register for shutdown operation
> - add power key resources
> - disallow x-powers,dcdc-freq in the DT binding
> - drop unused OUTPUT_MONITOR register name, add SHUTDOWN_CTRL
> - require dcdcfreq being 0 (non-present DT property default)
>
> v7 .. v8:
> - Add check for dcdcfreq being zero
>
> v6 .. v7:
> - Use alphabetical ordering
>
> v5 .. v6:
> - change name from AXP1530 to AXP313a
> - extend commit messages
> - drop AXP*_FREQUENCY register (not used anyway)
> - better vertically align struct definitions
> - rename IRQs to match names used for other PMICs
> - add RTC_LDO regulator
> - use decimal numbers for selector ranges
> - use macro definitions to name some values
> - force DC/DC switching frequency to be fixed at 3 MHz
> - change LDO source supply to VIN1 (as per datasheet)
>
> v4 .. v5:
> - Use alphabetical ordering in mfd
> - Correct { placement line
> - Replace spaces with tabs in 1 struct
>
> v3 .. v4:
> - Fix indentation
>
> v2 .. v3:
> - Move AXP1530 dt-binding to alphabetical order
>
> v1 .. v2:
> - Remove RSB support.
> - Drop .id = 0
> - Add dt-binding for the AXP1530
>
> AXP15060:
> v2 .. v3:
> - Rebase to AXP313a series v10 [1] + newest (20230420) -next branch
> - Disables DC-DC frequency setting
> - Add axp_regulator_only_cells rather than directly using axp806_cells
> for cases that IRQ line isn't connected.
> - Fix some whitespace
> - Rename swout to sw to keep up with bindings
> - Add check for setting DC-DC frequency
>
> v1 .. v2:
> - Move cpusldo before drivevbus (Krzysztof Kozlowski)
>
>
> Martin Botka (2):
> mfd: axp20x: Add support for AXP313a PMIC
> regulator: axp20x: Add support for AXP313a variant
>
> Shengyu Qu (1):
> regulator: axp20x: Add AXP15060 support
>
> drivers/mfd/axp20x-i2c.c | 2 +
> drivers/mfd/axp20x.c | 78 ++++++-
> drivers/regulator/axp20x-regulator.c | 290 ++++++++++++++++++++++++++-
> include/linux/mfd/axp20x.h | 32 +++
> 4 files changed, 393 insertions(+), 9 deletions(-)
>
[unhandled content-type:application/pgp-keys][unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2023-05-24 11:13    [W:0.794 / U:0.092 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site