Messages in this thread |  | | Date | Wed, 20 Dec 2023 08:53:48 +0800 | | Subject | Re: [PATCH v3 1/1] arm64: dts: qcom: sm8550: remove address/size-cells from mdss_dsi1 | | From | "Aiqun Yu (Maria)" <> |
| |
On 12/19/2023 6:21 PM, Dmitry Baryshkov wrote: > On Tue, 19 Dec 2023 at 12:09, Aiqun Yu (Maria) <quic_aiquny@quicinc.com> wrote: >> >> >> >> On 12/19/2023 5:41 PM, Krzysztof Kozlowski wrote: >>> On 19/12/2023 10:36, Aiqun Yu (Maria) wrote: >>>> >>>> >>>> On 12/19/2023 3:17 PM, Krzysztof Kozlowski wrote: >>>>> On 19/12/2023 01:31, Tengfei Fan wrote: >>>>>> The address/size-cells in mdss_dsi1 node have not ranges and child also >>>>>> have not reg, then this leads to dtc W=1 warnings: >>>>> >>>> Comments can be more readable: >>>> "mdss_dsi1" node don't have "ranges" or child "reg" property, while it >>>> have address/size-cells properties. This caused >>>> "avoid_unnecessary_addr_size" warning from dtb check. >>>> Remove address/size-cells properties for "mdss_dsi1" node. >>>> >>>>> I cannot parse it. Address/size cells never have ranges or children. >>>>> They cannot have. These are uint32 properties. >>>> Pls help to comment on the revised commit message. Every time I write a >>>> commit message, also takes a while for me to double confirm whether >>>> others can understand me correctly as well. Feel free to let us know if >>>> it is not readable to you. It will help us as non-English native developers. >>>>> >>>>>> >>>>>> sm8550.dtsi:2937.27-2992.6: Warning (avoid_unnecessary_addr_size): /soc@0/display-subsystem@ae00000/dsi@ae96000: >>>>>> unnecessary #address-cells/#size-cells without "ranges" or child "reg" property >>>>>> >>>>>> >>>>>> Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org> >>>>>> Signed-off-by: Tengfei Fan <quic_tengfan@quicinc.com> >>>>>> --- >>>>> >>>>> I disagreed with the patch before. You resubmit it without really >>>>> addressing my concerns. >>>>> >>>>> I am not sure if this is correct fix and I want to fix all of such >>>>> errors (there are multiple of them) in the same way. Feel free to >>>>> propose common solution based on arguments. >>>> Per my understanding, "qcom,mdss-dsi-ctrl" driver node like "mdss_dsi1" >>>> don't need to have address/size-cells properties. >>> >>> Just because dtc says so? And what about bindings? >> I don't find any reason why "qcom,mdss-dsi-ctrl" driver node need to >> have address/size-cells properties. Document Bindings should also be fixed. >>> >>>> Feel free to let us know whether there is different idea of >>>> "address/size-cells" needed for the "qcom,mdss-dsi-ctrl" driver node. >>> >>> The bindings expressed that idea. If the binding is incorrect, fix the >>> binding and the DTS. If the binding is correct, provide rationale why it >>> somehow does not apply here etc. >> Our plan is to fix the bindings as well. >> >> In case you have missed the question, I just re-place it here: >> While there are about 22 different soc dtsi and it's document binding >> files needed to be fixed. Shall we fix it for all qcom related soc usage >> in one patch, or we'd better to split into different patches according >> to soc specifically? > > Don't touch the bindings unless you understand what you are doing. > Your patch will be NAKed. There can be a DSI panel attached to the DSI > host, which means there is a need for #address-cells / #size-cells. > Could you please help to elaborate more on details? Like what's the right example here for the "qcom,mdss-dsi-ctrl" driver node needed to have "#address-cells"/"#size-cells".
Thx to chime in that we have put a good amount of time here. > Please stop wasting the time on dtc warning. The bindings (and the > file) are correct. I don't agree here. Either it is a wrong usage of "#address-cells"/"#size-cells", or dtc warning should be fixed with this usage take into account. "dtb check" will be a good guideline for developers to follow, I don't think it is wasting time here. >
-- Thx and BRs, Aiqun(Maria) Yu
|  |