lkml.org 
[lkml]   [2022]   [Sep]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: [PATCH] hv: Use PCI_VENDOR_ID_MICROSOFT for better discoverability
Date
From: Michael Kelley (LINUX) <mikelley@microsoft.com> Sent: Thursday, September 22, 2022 3:39 PM
>
> From: Easwar Hariharan <eahariha@linux.microsoft.com> Sent: Monday, September
> 19, 2022 3:05 PM
> >
> > pci_ids.h already defines PCI_VENDOR_ID_MICROSOFT, and is included via
> > linux/pci.h. Use the define instead of the magic number.
> >
> > Signed-off-by: Easwar Hariharan <easwar.hariharan@microsoft.com>
> > ---
> > drivers/hv/vmbus_drv.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
> > index 3c833ea..f2efb74 100644
> > --- a/drivers/hv/vmbus_drv.c
> > +++ b/drivers/hv/vmbus_drv.c
> > @@ -2052,7 +2052,7 @@ struct hv_device *vmbus_device_create(const guid_t
> *type,
> > child_device_obj->channel = channel;
> > guid_copy(&child_device_obj->dev_type, type);
> > guid_copy(&child_device_obj->dev_instance, instance);
> > - child_device_obj->vendor_id = 0x1414; /* MSFT vendor ID */
> > + child_device_obj->vendor_id = PCI_VENDOR_ID_MICROSOFT;
> >
> > return child_device_obj;
> > }
> > --
> > 1.8.3.1
>
> Reviewed-by: Michael Kelley <mikelley@microsoft.com>

Actually, a nit: The short commit message should start with "Drivers: hv:" or
"Drivers: hv: vmbus:". Check the commit history on vmbus_drv.c and you'll
see the standard usage.

Michael

\
 
 \ /
  Last update: 2022-09-23 00:45    [W:0.051 / U:0.900 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site