lkml.org 
[lkml]   [2022]   [Jun]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 3/4] x86/cpuid: move filter_cpuid_features to cpuid-deps.c
From
Date
On Wed, 2022-06-22 at 08:07 -0700, Dave Hansen wrote:
> On 6/22/22 07:48, Maxim Levitsky wrote:
> > No functional change intended.
>
> It would be really nice to at least write a "why" sentence. You wrote
> the "what" (move code), but I have no idea why you are moving it.

This is a good point, I will add a justification in V2.

>
> > arch/x86/kernel/cpu/common.c | 46 -----------------------------
> > arch/x86/kernel/cpu/cpuid-deps.c | 48 +++++++++++++++++++++++++++++++
>
> That looks a wee bit odd for a code move. Where did the 2 lines go?
>
> > diff --git a/arch/x86/include/asm/cpufeature.h b/arch/x86/include/asm/cpufeature.h
> > index ea34cc31b0474f..3eb5fe0d654e63 100644
> > --- a/arch/x86/include/asm/cpufeature.h
> > +++ b/arch/x86/include/asm/cpufeature.h
> > @@ -147,6 +147,7 @@ extern const char * const x86_bug_flags[NBUGINTS*32];
> >
> > extern void setup_clear_cpu_cap(unsigned int bit);
> > extern void clear_cpu_cap(struct cpuinfo_x86 *c, unsigned int bit);
> > +extern void filter_cpuid_features(struct cpuinfo_x86 *c, bool warn);
> >
> > #define setup_force_cpu_cap(bit) do { \
> > set_cpu_cap(&boot_cpu_data, bit); \
> > diff --git a/arch/x86/kernel/cpu/common.c b/arch/x86/kernel/cpu/common.c
> > index 4730b0a58f24a5..4cc79971d2d847 100644
> > --- a/arch/x86/kernel/cpu/common.c
> > +++ b/arch/x86/kernel/cpu/common.c
> > @@ -620,52 +620,6 @@ __noendbr void cet_disable(void)
> > wrmsrl(MSR_IA32_S_CET, 0);
> > }
> >
> > -/*
> ...
> > -}
> >
> > /*
> > * Naming convention should be: <Name> [(<Codename>)]
>
> One, by leaving extra whitespace.
>
> > diff --git a/arch/x86/kernel/cpu/cpuid-deps.c b/arch/x86/kernel/cpu/cpuid-deps.c
> > index d6777d07ba3302..bcb091d02a754b 100644
> > --- a/arch/x86/kernel/cpu/cpuid-deps.c
> > +++ b/arch/x86/kernel/cpu/cpuid-deps.c
> > @@ -131,3 +131,51 @@ void setup_clear_cpu_cap(unsigned int feature)
> > {
> > clear_cpu_cap(&boot_cpu_data, feature);
> > }
> > +
> > +
> > +/*
>
> Two, by adding extra whitespace.
>

I will fix this, I didn't notice that I added new lines.
Next time I move code around, I'll check that the number count matches.

Thanks!
Best regards,
Maxim Levitsky

\
 
 \ /
  Last update: 2022-06-22 18:03    [W:0.076 / U:0.896 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site