lkml.org 
[lkml]   [2022]   [Feb]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/2] hwmon: (adm1275) Allow setting sample averaging
On 2/23/22 08:38, Potin Lai wrote:
> Current driver assume PWR_AVG and VI_AVG as 1 by default, and user needs to
> set sample averaging via sysfs manually.
>
> This patch parses "pwr-avg" and "vi-avg" from device tree, and setting
> sample averaging during probe.
>
> Signed-off-by: Potin Lai <potin.lai@quantatw.com>
> ---
> drivers/hwmon/pmbus/adm1275.c | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
> diff --git a/drivers/hwmon/pmbus/adm1275.c b/drivers/hwmon/pmbus/adm1275.c
> index d311e0557401..97faff4e3111 100644
> --- a/drivers/hwmon/pmbus/adm1275.c
> +++ b/drivers/hwmon/pmbus/adm1275.c
> @@ -475,6 +475,7 @@ static int adm1275_probe(struct i2c_client *client)
> int vindex = -1, voindex = -1, cindex = -1, pindex = -1;
> int tindex = -1;
> u32 shunt;
> + u32 avg;
>
> if (!i2c_check_functionality(client->adapter,
> I2C_FUNC_SMBUS_READ_BYTE_DATA
> @@ -756,6 +757,30 @@ static int adm1275_probe(struct i2c_client *client)
> return -ENODEV;
> }
>
> + if (data->have_power_sampling &&
> + of_property_read_u32(client->dev.of_node,
> + "pwr-avg", &avg) == 0) {

Those properties will need a better name and will have to be prefixed
by the chip vendor.

> + avg = clamp_val(avg, 1, ADM1275_SAMPLES_AVG_MAX);

clamp_val() is inappropriate for devicetree properties.
The property definition needs to include a valid range, and that range
needs to be validated and rejected if invalid.

> + ret = adm1275_write_pmon_config(data, client,
> + true, ilog2(avg));
> + if (ret < 0) {
> + dev_err(&client->dev, "set pwr-avg failed, ret = %d",
> + ret);
> + return ret;
> + }
> + }
> +
> + if (of_property_read_u32(client->dev.of_node, "vi-avg", &avg) == 0) {
> + avg = clamp_val(avg, 1, ADM1275_SAMPLES_AVG_MAX);
> + ret = adm1275_write_pmon_config(data, client,
> + false, ilog2(avg));
> + if (ret < 0) {
> + dev_err(&client->dev, "set vi-avg failed, ret = %d",

This needs to be more descriptive, eg "Setting voltage average failed, ...".
Same above.

> + ret);
> + return ret;
> + }
> + }
> +
> if (voindex < 0)
> voindex = vindex;
> if (vindex >= 0) {

\
 
 \ /
  Last update: 2022-02-23 18:11    [W:0.349 / U:0.012 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site