lkml.org 
[lkml]   [2022]   [Dec]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] spi: dw_bt1: fix MUX_MMIO dependencies
On Sun, Dec 18, 2022, at 15:22, Serge Semin wrote:
> Hi Arnd
>
> On Thu, Dec 15, 2022 at 05:52:34PM +0100, Arnd Bergmann wrote:
>> From: Arnd Bergmann <arnd@arndb.de>
>>
>> Selecting a symbol with additional dependencies requires
>> adding the same dependency here:
>>
>> WARNING: unmet direct dependencies detected for MUX_MMIO
>> Depends on [n]: MULTIPLEXER [=y] && OF [=n]
>> Selected by [y]:
>> - SPI_DW_BT1 [=y] && SPI [=y] && SPI_MASTER [=y] && SPI_DESIGNWARE [=y] && (MIPS_BAIKAL_T1 || COMPILE_TEST [=y])
>>
>> Alternatively, we could drop this 'select' and require users to manually
>> put it into their .config as we do for other drivers.
>
> Thanks for the patch. Seeing the driver is only implicitly dependent
> from the mux-mmio driver (via the device described in the device tree
> blob) I'd suggest to either drop the MUX_MMIO config reverse
> dependency or convert it to the weak one - 'imply' (if it will solve
> the problem).

Ok, I'll send a new patch. I don't want to use 'imply' though, that
tends to cause other problems because almost nobody understands what
it actually does.

Arnd

\
 
 \ /
  Last update: 2022-12-18 19:30    [W:0.036 / U:0.168 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site