lkml.org 
[lkml]   [2022]   [Nov]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v2 0/5] exfat: move exfat_entry_set_cache from heap to stack
Looks good.
Thanks for your patchset.

Reviewed-by: Sungjong Seo <sj1557.seo@samsung.com>

> This patchset reduces the size of exfat_entry_set_cache and moves
> it from heap to stack.
>
> Changes for v2:
> * [1/5] [5/5]
> - Rename ES_*_ENTRY to ES_IDX_*
> - Fix ES_IDX_LAST_FILENAME() to return the index of the last
> filename entry
> - Add ES_ENTRY_NUM() MACRO
>
> Yuezhang Mo (5):
> exfat: reduce the size of exfat_entry_set_cache
> exfat: support dynamic allocate bh for exfat_entry_set_cache
> exfat: move exfat_entry_set_cache from heap to stack
> exfat: rename exfat_free_dentry_set() to exfat_put_dentry_set()
> exfat: replace magic numbers with Macros
>
> fs/exfat/dir.c | 70 ++++++++++++++++++++++++++-------------------
> fs/exfat/exfat_fs.h | 37 ++++++++++++++++++------
> fs/exfat/inode.c | 13 ++++-----
> fs/exfat/namei.c | 11 ++++---
> 4 files changed, 80 insertions(+), 51 deletions(-)

\
 
 \ /
  Last update: 2022-11-24 14:02    [W:0.546 / U:0.000 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site