lkml.org 
[lkml]   [2022]   [Nov]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [patch 02/20] genirq/irqdomain: Rename irq_domain::dev to irq_domain::pm_dev
Date
On Wed, Nov 16 2022 at 14:22, Jason Gunthorpe wrote:
>> + if (gic->domain->pm_dev)
>> + seq_printf(p, gic->domain->pm_dev->of_node->name);
>
> This looks a bit odd now? I guess it still prints something meaningful
> to debugfs but I suppose this would someday make more sense to be the
> ::dev version?

Maybe, but for now I just want to keep it compatible.

>> --- a/include/linux/irqdomain.h
>> +++ b/include/linux/irqdomain.h
>> @@ -117,53 +117,53 @@ struct irq_domain_chip_generic;
>>
>> /**
>> * struct irq_domain - Hardware interrupt number translation object
>> - * @link: Element in global irq_domain list.
>> - * @name: Name of interrupt domain
>> - * @ops: pointer to irq_domain methods
>> - * @host_data: private data pointer for use by owner. Not touched by irq_domain
>> - * core code.
>> - * @flags: host per irq_domain flags
>> - * @mapcount: The number of mapped interrupts
>> + * @link: Element in global irq_domain list.
>> + * @name: Name of interrupt domain
>> + * @ops: Pointer to irq_domain methods
>
> Maybe all this whitespace change would like to be in its own patch?

Yes.

\
 
 \ /
  Last update: 2022-11-17 16:56    [W:0.062 / U:0.200 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site