lkml.org 
[lkml]   [2022]   [Jan]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v11 0/3] mmc: Add LiteSDCard mmc driver
Date
Add support for the LiteX SD-Card device, LiteSDCard.

LiteSDCard is a simple SD-Card interface available as part of the LiteX
environment, used with various RISC-V and other FPGA based SoCs.

New in v11:
- picked up r/b from Andy
drivers/mmc/host/litex_mmc.c:
- defensive coding of litex_mmc_interrupt() return logic
- remove `dev` member of `struct litex_mmc_host`, only used during probe

>New in v10:
>drivers/mmc/host/litex_mmc.c:
> - group `linux/mmc/*` includes by themselves
> - clean-up of `return` style (multiple locations throughout source)
> - create `mmc_free_host()` wrapper for use with
> `devm_add_action_or_reset()`
> - use GFP_KERNEL with `dmam_alloc_coherent()`
>
>>New in v9:
>>drivers/mmc/host/Kconfig:
>> - fix OF dependency
>>drivers/mmc/host/litex_mmc.c:
>> - remove `linux/of.h` include, no longer needed since dropping
>> `of_match_ptr()`
>> - add `linux/mod_devicetable.h` include
>> - use devm_action_or_reset() to devm-ify mmc_alloc_host(), and obviate
>> the need to call mmc_free_host() explicitly during either probe()
>> error path or during remove()
>>
>>>New in v8:
>>>commit blurbs:
>>> - cosmetic editing of descriptions
>>> - removed `Cc:` lines
>>>drivers/mmc/host/litex_mmc.c:
>>> - fix file header comment (for real, this time)
>>> - add explicit `bits.h` include
>>> - remove `of_match_ptr()` wrapper from around .of_match_table argument
>>> - fix devm ordering issues: use `devm_request_irq()`, which precludes
>>> the need to call `free_irq()` on `probe()` error path or from `remove()`
>>>
>>>>New in v7:
>>>>
>>>>drivers/mmc/host/Kconfig:
>>>> - added module name in LiteSDCard Kconfig entry
>>>>
>>>>drivers/mmc/host/litex_mmc.c:
>>>> - fixed comment formatting, ordering, and capitalization throughout
>>>> the entire file
>>>> - sorted header #include statements
>>>> - removed redundant parantheses in readx_poll_timeout() condition
>>>> - explicit handling of readx_poll_timeout() timeout scenarios
>>>> - dev_err() used in litex_mmc_sdcard_wait_done()
>>>> - use memcpy_fromio() to grab command response
>>>> - no need to apply 0xffff mask to a 32-bit value right-shifted by 16
>>>> (host->resp[3])
>>>> - use clamp() instead of min(max(...)...)
>>>> - reworked platform_get_irq_optional() error handling logic
>>>> - no need to explicitly zero host->irq, kzalloc() does that already
>>>> - added missing free_irq() in litex_mmc_probe() error path
>>>> - reordered calls inside litex_mmc_remove() (calling mmc_free_host()
>>>> before free_irq()
>>>>
>>>>>New in v6:
>>>>>
>>>>>drivers/mmc/host/litex_mmc.c:
>>>>> - fix handling of deferred probe vs. platform_get_irq_optional()
>>>>> - don't #ifdef dma_set_mask_and_coherent(), since it automatically
>>>>> does the right thing on both 32- and 64-bit DMA capable arches
>>>>> - remove MMC_CAP2_FULL_PWR_CYCLE, add MMC_CAP2_NO_MMC to list of
>>>>> hardcoded capabilities during litex_mmc_probe()
>>>>> - hardcode mmc->ocr_avail to the full 2.7-3.6V range allowed by the
>>>>> SDCard spec (the LiteSDCard device doesn't accept software
>>>>> configuration)
>>>>>
>>>>>>New in v5:
>>>>>>
>>>>>>MAINTAINERS:
>>>>>>
>>>>>> - picked up a/b Mateusz
>>>>>>
>>>>>>Doc/dt/bindings/mmc/litex,mmc.yaml:
>>>>>>
>>>>>> - picked up r/b Rob, Joel
>>>>>>
>>>>>>drivers/mmc/host/litex_mmc.c:
>>>>>>
>>>>>> - shorten #define constant names (cosmetic, make them less unwieldy)
>>>>>> - picked up r/b Joel
>>>>>>
>>>>>>>New in v4:
>>>>>>>
>>>>>>>Doc/dt/bindings/mmc/litex,mmc.yaml:
>>>>>>>
>>>>>>> - fixed `dt_binding_check` errors uncovered by Rob's script
>>>>>>>
>>>>>>>drivers/mmc/host/litex_mmc.c:
>>>>>>>
>>>>>>> - struct litex_mmc_host fields re-ordered so that `pahole` reports
>>>>>>> no holes in either 32- or 64-bit builds
>>>>>>> - litex_mmc_set_bus_width() now encapsulates check for
>>>>>>> host->is_bus_width_set
>>>>>>> - litex_mmc_request() - factor out dma data setup into separate
>>>>>>> helper function: litex_mmc_do_dma()
>>>>>>>
>>>>>>>>New in v3:
>>>>>>>>
>>>>>>>> MAINTAINERS:
>>>>>>>>
>>>>>>>> - picked up acked-by Joel
>>>>>>>> - added listing for liteeth driver
>>>>>>>> - added Joel as additional co-maintainer (thanks!)
>>>>>>>>
>>>>>>>> Doc/dt/bindings/mmc/litex,mmc.yaml:
>>>>>>>>
>>>>>>>> - picked up r/b Geert Uytterhoeven <geert@linux-m68k.org> in DT
>>>>>>>> bindings document (please let me know if that was premature, and
>>>>>>>> happy to take further review if needed :)
>>>>>>>> - add dedicated DT property for source clock frequency
>>>>>>>>
>>>>>>>> drivers/mmc/host/litex_mmc.c:
>>>>>>>>
>>>>>>>> - fixed function signature (no line split), and naming (litex_mmc_*)
>>>>>>>> - more informative MODULE_AUTHOR() entries
>>>>>>>> - also added matching "Copyright" entries in file header
>>>>>>>> - fixed description in Kconfig
>>>>>>>> - fixed DT documentation
>>>>>>>> - removed magic constants
>>>>>>>> - removed litex_map_status(), have sdcard_wait_done() return *real*
>>>>>>>> error codes directly instead.
>>>>>>>> - streamlined litex_mmc_reponse_len()
>>>>>>>> - call litex_mmc_set_bus_width() only once, and ensure it returns
>>>>>>>> correct error code(s)
>>>>>>>> - use readx_poll_timeout() -- more concise -- instead of
>>>>>>>> read_poll_timeout()
>>>>>>>> - use dev_err() in litex_mmc_send_cmd() (instead of pr_err())
>>>>>>>> - litex_mmc_setclk() will update host->clock before returning
>>>>>>>> - separate irq initialization into its own function,
>>>>>>>> litex_mmc_irq_init()
>>>>>>>> - document rationale for f_min, f_max
>>>>>>>> - use dmam_alloc_coherent(), which simplifies cleanup significantly
>>>>>>>> - large `if (data) { ... }` block in litex_mmc_request() left as-is,
>>>>>>>> there are too many variables shared with the rest of the parent
>>>>>>>> function body to easily separate (e.g., `len`, `transfer`, `direct`).
>>>>>>>> If this is indeed a blocker, I can take another shot at refactoring
>>>>>>>> it in a future revision!
>>>>>>>> - bump dma_set_mask_and_coherent() to 64-bits on suitable
>>>>>>>> architectures
>>>>>>>> - clock source picked up from dedicated DT clock reference property
>>>>>>>> - remove gpio card-detect logic (needs testing and a dt binding
>>>>>>>> example before being eligible for upstream inclusion)
>>>>>>>>
>>>>>>>>> New in v2:
>>>>>>>>> - reword info message in litex_set_clk()
>>>>>>>>> - streamline code in litex_map_status()
>>>>>>>>> - fix typos in Kconfig (thanks Randy Dunlap <rdunlap@infradead.org>)
>>>>>>>>> - improvements suggested by Stafford Horne <shorne@gmail.com>
>>>>>>>>> - allow COMPILE_TEST in Kconfig
>>>>>>>>> - use read_poll_timeout() when waiting for cmd/data/DMA
>>>>>>>>> xfer completion
>>>>>>>>> - include interrupt.h (thanks kernel test robot <lkp@intel.com>)

Gabriel Somlo (3):
MAINTAINERS: co-maintain LiteX platform
dt-bindings: mmc: Add bindings for LiteSDCard
mmc: Add driver for LiteX's LiteSDCard interface

.../devicetree/bindings/mmc/litex,mmc.yaml | 72 ++
MAINTAINERS | 9 +-
drivers/mmc/host/Kconfig | 9 +
drivers/mmc/host/Makefile | 1 +
drivers/mmc/host/litex_mmc.c | 657 ++++++++++++++++++
5 files changed, 746 insertions(+), 2 deletions(-)
create mode 100644 Documentation/devicetree/bindings/mmc/litex,mmc.yaml
create mode 100644 drivers/mmc/host/litex_mmc.c

--
2.31.1

\
 
 \ /
  Last update: 2022-01-10 00:20    [W:0.263 / U:0.040 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site