lkml.org 
[lkml]   [2022]   [Jan]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] KVM: x86: enhance the readability of function pic_intack()
Date
From: wangguangju <wangguangju@baidu.com>

In function pic_intack(), use a varibale of "mask" to
record expression of "1 << irq", so we can enhance the
readability of this function.

Signed-off-by: wangguangju <wangguangju@baidu.com>
---
arch/x86/kvm/i8259.c | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/arch/x86/kvm/i8259.c b/arch/x86/kvm/i8259.c
index 814064d06016..ad6b64b11adc 100644
--- a/arch/x86/kvm/i8259.c
+++ b/arch/x86/kvm/i8259.c
@@ -216,12 +216,14 @@ void kvm_pic_clear_all(struct kvm_pic *s, int irq_source_id)
*/
static inline void pic_intack(struct kvm_kpic_state *s, int irq)
{
- s->isr |= 1 << irq;
+ int mask;
+ mask = 1 << irq;
+ s->isr |= mask;
/*
* We don't clear a level sensitive interrupt here
*/
- if (!(s->elcr & (1 << irq)))
- s->irr &= ~(1 << irq);
+ if (!(s->elcr & mask))
+ s->irr &= ~mask;

if (s->auto_eoi) {
if (s->rotate_on_auto_eoi)
--
2.25.1
\
 
 \ /
  Last update: 2022-01-13 10:45    [W:0.038 / U:0.460 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site