lkml.org 
[lkml]   [2021]   [Sep]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 02/10] regmap: spi: Check raw_[read|write] against max message size
On Wed, Sep 08, 2021 at 12:34:43PM +0100, Lucas Tanure wrote:
> regmap-spi will split data and address between two transfers
> in the same message, so max_[read|write] must include space
> for the address and padding
>
> Signed-off-by: Lucas Tanure <tanureal@opensource.cirrus.com>
> ---
> drivers/base/regmap/regmap-spi.c | 4 ++++
> drivers/base/regmap/regmap.c | 15 +++++++++++++++
> include/linux/regmap.h | 3 +++
> 3 files changed, 22 insertions(+)
>
> diff --git a/drivers/base/regmap/regmap-spi.c b/drivers/base/regmap/regmap-spi.c
> index 0e6552e57ecf..1434c502e340 100644
> --- a/drivers/base/regmap/regmap-spi.c
> +++ b/drivers/base/regmap/regmap-spi.c
> @@ -123,6 +123,10 @@ static const struct regmap_bus *regmap_get_spi_bus(struct spi_device *spi,
> bus->free_on_exit = true;
> bus->max_raw_read = max_size;
> bus->max_raw_write = max_size;
> +
> + if (spi_max_message_size(spi) != SIZE_MAX)
> + bus->max_combined_rw = spi_max_message_size(spi);

I am not sure max_combined_rw is the best name here, it makes
sense in a SPI context where reads are a write followed by a
read. But does it really make sense for all buses? Like an MMIO
this no longer seems a very meaningful name.

Perhaps max_transaction? But I am often not the best at thinking
of names myself.

> +
> return bus;
> }
>
> diff --git a/drivers/base/regmap/regmap.c b/drivers/base/regmap/regmap.c
> index fe3e38dd5324..1cd936e097b0 100644
> --- a/drivers/base/regmap/regmap.c
> +++ b/drivers/base/regmap/regmap.c
> @@ -718,6 +718,7 @@ struct regmap *__regmap_init(struct device *dev,
> struct regmap *map;
> int ret = -EINVAL;
> enum regmap_endian reg_endian, val_endian;
> + size_t reg_pad_size;
> int i, j;
>
> if (!config)
> @@ -815,6 +816,20 @@ struct regmap *__regmap_init(struct device *dev,
> if (bus) {
> map->max_raw_read = bus->max_raw_read;
> map->max_raw_write = bus->max_raw_write;
> + if (bus->max_combined_rw) {
> + reg_pad_size = map->format.reg_bytes + map->format.pad_bytes;

Maybe reg_overhead_size or something? This line uses pad to both
mean the actual padding in pad_bytes and to mean address +
padding in reg_pad_size.

Thanks,
Charles

\
 
 \ /
  Last update: 2022-09-17 16:11    [W:0.143 / U:0.992 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site