lkml.org 
[lkml]   [2021]   [Sep]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v17 05/15] arm64: kexec: skip relocation code for inplace kexec
Hi Will,

> > + cpu_install_idmap();
> > + restart = (void *)__pa_symbol(function_nocfi(__cpu_soft_restart));
> > + restart(is_hyp_nvhe(), kimage->start, kimage->arch.dtb_mem,
> > + 0, 0);
>
> Why can't you call:
>
> cpu_soft_restart(kimage->start, kimage->arch.dtb_mem, 0, 0);
>
> here instead of open-coding it?

This is part of a cleanup to remove cpu_soft_restart() wrapper and the
header file that contains it. The wrapper is simple enough and has
only one call site. It makes more sense to do what is needed directly
from machine_kexec().

Pasha

\
 
 \ /
  Last update: 2021-09-30 04:46    [W:0.095 / U:0.044 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site