lkml.org 
[lkml]   [2021]   [Sep]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Date
    SubjectRe: [PATCH v6 0/2] Add p2p via dmabuf to habanalabs
    On Tue, Sep 14, 2021 at 5:18 PM Daniel Vetter <daniel@ffwll.ch> wrote:
    >
    > On Sun, Sep 12, 2021 at 07:53:07PM +0300, Oded Gabbay wrote:
    > > Hi,
    > > Re-sending this patch-set following the release of our user-space TPC
    > > compiler and runtime library.
    > >
    > > I would appreciate a review on this.
    >
    > I think the big open we have is the entire revoke discussions. Having the
    > option to let dma-buf hang around which map to random local memory ranges,
    > without clear ownership link and a way to kill it sounds bad to me.
    >
    Hi Daniel, thanks for the reply.

    What is this revocation requirement ?
    Is it relevant to my case, where our device has a single user at a
    time (only a single process can open the device character file) and
    that user has ownership of the entire device local memory ?

    Because I don't care if the user has this dma-buf object lying around,
    as it only wastes device memory for that user. And the user can't
    close the fd of the device until it has closed the fd of the dmabuf.

    Or is the revocation referring to something else entirely ?

    > I think there's a few options:
    > - We require revoke support. But I've heard rdma really doesn't like that,
    > I guess because taking out an MR while holding the dma_resv_lock would
    > be an inversion, so can't be done. Jason, can you recap what exactly the
    > hold-up was again that makes this a no-go?
    >
    > - The other option I discussed is a bit more the exlusive device ownership
    > model we've had for gpus in drm of the really old kind. Roughly this
    > would work like this, in terms of drm_device:
    > - Only the current owner (drm_master in current drm code, but should
    > probably rename that to drm_owner) is allowed to use the accel driver.
    > So all ioctl would fail if you're not drm_master.
    > - On dropmaster/file close we'd revoke as much as possible, e.g.
    > in-flight commands, mmaps, anything really that can be revoked.
    > - For non-revokable things like these dma-buf we'd keep a drm_master
    > reference around. This would prevent the next open to acquire
    > ownership rights, which at least prevents all the nasty potential
    > problems.
    > - admin (or well container orchestrator) then has responsibility to
    > shoot down all process until the problem goes away (i.e. until you hit
    > the one with the rdma MR which keeps the dma-buf alive)
    >
    > - Not sure there's another reasonable way to do this without inviting some
    > problems once we get outside of the "single kernel instance per tenant"
    > use-case.
    >
    > Wrt implementation there's the trouble of this reinventing a bunch of drm
    > stuff and concepts, but that's maybe for after we've figured out
    > semantics.
    >
    > Also would be great if you have a pull request for the userspace runtime
    > that shows a bit how this all gets used and tied together. Or maybe some
    > pointers, since I guess retconning a PR in github is maybe a bit much.

    hmm.. so actually this has only an API in the hl-thunk library. I have
    not put it in github but I can do it fairly quickly.
    But the callee of this API is not the userspace runtime. The callee is
    another library which is responsible for doing scale-out of training
    outside of a box of gaudi devices. That library implements collective
    operations (e.g. all gather, all reduce) over multiple gaudi devices.
    And in fact, the real user is the training framework (e.g. tensorflow,
    pytorch) that calls these collective operations. The framework then
    passes the dmabuf fd to libfabric (open source project) which uses
    rdma-core to pass it to the rdma driver.

    I can give you a short presentation on that if you want :)

    >
    > Cheers, Daniel
    >
    > >
    > > Thanks,
    > > Oded
    > >
    > > Oded Gabbay (1):
    > > habanalabs: define uAPI to export FD for DMA-BUF
    > >
    > > Tomer Tayar (1):
    > > habanalabs: add support for dma-buf exporter
    > >
    > > drivers/misc/habanalabs/Kconfig | 1 +
    > > drivers/misc/habanalabs/common/habanalabs.h | 22 +
    > > drivers/misc/habanalabs/common/memory.c | 522 +++++++++++++++++++-
    > > drivers/misc/habanalabs/gaudi/gaudi.c | 1 +
    > > drivers/misc/habanalabs/goya/goya.c | 1 +
    > > include/uapi/misc/habanalabs.h | 28 +-
    > > 6 files changed, 570 insertions(+), 5 deletions(-)
    > >
    > > --
    > > 2.17.1
    > >
    >
    > --
    > Daniel Vetter
    > Software Engineer, Intel Corporation
    > http://blog.ffwll.ch

    \
     
     \ /
      Last update: 2021-09-14 16:59    [W:2.560 / U:0.064 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site