lkml.org 
[lkml]   [2021]   [Jul]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH V8 0/4] soc: imx: add i.MX BLK-CTL support
From
Date
On 02.07.21 05:24, Peng Fan wrote:
> All,
>
>> Subject: Re: [PATCH V8 0/4] soc: imx: add i.MX BLK-CTL support
>>
>> On 30.06.21 19:20, Frieder Schrempf wrote:
>>> On 30.06.21 18:28, Marek Vasut wrote:
>>>> On 6/30/21 4:46 PM, Frieder Schrempf wrote:
>>>>> On 30.06.21 14:09, Adam Ford wrote:
>>>>>> On Wed, Jun 30, 2021 at 4:34 AM Peng Fan (OSS)
>> <peng.fan@oss.nxp.com> wrote:
>>>>>>>
>>>>>>>> Subject: Re: [PATCH V8 0/4] soc: imx: add i.MX BLK-CTL support
>>>>>>>>
>>>>>>>> On Tue, Jun 29, 2021 at 1:56 AM Peng Fan (OSS)
>>>>>>>> <peng.fan@oss.nxp.com>
>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>> From: Peng Fan <peng.fan@nxp.com>
>>>>>>>>>
>>>>>>>>> V8:
>>>>>>>>> Revert one change in v7, force goto disable_clk for handshake
>>>>>>>>> when power on in patch 3 One minor update to use if{} else {},
>>>>>>>>> not if{}; if{}; in patch 3 Typo Hankshake->Handshake
>>>>>>>>>
>>>>>>>> I am using ATF, branch lf_v2.4, from the NXP code aurora repo
>>>>>>>> with U-Boot
>>>>>>>> v2021.07-rc5
>>>>>>>>
>>>>>>>> I applied this patch against linux-next, I applied the pgc
>>>>>>>> patches [1], and the suggested power-domains to the otg1 and otg2
>> nodes.
>>>>>>>> I am able to boot the device and use USB, but with this applied,
>>>>>>>> I cannot wake from sleep.  If I revert this, the system wakes from
>> sleep again.
>>>>>>>
>>>>>>> I just tried linux-next without this patch on iMX8MM EVK,
>>>>>>> suspend/resume not work. Per my last test, it works before. Not sure
>> what changed in kernel.
>>>>>>>
>>>>>>> Which kernel are you using, any commit or git repo? I could try on
>>>>>>> imx8mm evk and debug the issue you see.
>>>>>>
>>>>>> I used kernel-next,
>>>>>> git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git
>>>>>> commit 889bab4c367a0ef58208fd80fafa74bb6e2dca26 (tag:
>>>>>> next-20210621)
>>>>>>
>>>>>> I then applied the GPCv2 patch that Marek sent.  You were CC'd on
>>>>>> the e-mail from Marek, but I can forward the patch to you if you
>>>>>> can't find it.
>>>>>> I tested his patch and I was able to suspend-to-RAM and resume.
>>>>>> Once I was comfortable that it worked, I then applied your patch
>>>>>> series for the blk-ctl.
>>>>>> With the blk-ctl series applied, the suspend-resume stopped working.
>>>>>
>>>>> Same here. I tested with linux-next-20210629 and as soon as I add the
>> BLK-CTL driver and devicetree nodes, the resume after suspend causes a
>> lockup each time.
>>>>
>>>> btw do you have etnaviv enabled ?
>>>
>>> yes, but I can try without and see if it's related.
>>
>> It looks like the issue is not GPU-related. It appears once I add the
>> pgc_dispmix, pgc_mipi and dispmix_blk_ctl nodes to the dt (even without any
>> users, so lcdif and dsim are disabled). Once I remove the three nodes the
>> issue is gone.
>
>
> I have an updated code here:
> https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2FMrVan%2Flinux%2Ftree%2Flinux-next-master-628-blk-ctl-test&amp;data=04%7C01%7Cfrieder.schrempf%40kontron.de%7C1ff517847da04f73218f08d93d08effc%7C8c9d3c973fd941c8a2b1646f3942daf1%7C0%7C0%7C637607930865259413%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=p5xGgid7lnfEpGK5TbljHrn0B1b0oF%2FO39G81UyXhyY%3D&amp;reserved=0
>
> Only have blk-ctl,gpc,pd update. Please help test with applying your
> local patches with some peripherals enabled.
>
> I tested the upper code with suspend/resume with uart wakeup,
> it not hang anymore.

Sorry, but in my case I can't boot this version at all. It always locks up at boot.

\
 
 \ /
  Last update: 2021-07-05 12:47    [W:3.785 / U:0.028 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site