lkml.org 
[lkml]   [2021]   [Jul]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] docs/zh_CN: Remove the Microsoft rhetoric
Date
Update Chinese translation on par with original English coding-style.rst
Related commit b7592e5b82db19b72a34b471f3296ad3f651c8b9

Signed-off-by: Hu Jialun <hujialun@comp.nus.edu.sg>
---
This is more of a crude first attempt to begin getting accustomed to
mailing list conventions of open-source communities.
While efforts have been made to conform to the patch submission
conventions, there is still inevitably certain omissions.
Any corrections and suggestions would be greatly appreciated! :)

Documentation/translations/zh_CN/process/coding-style.rst | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/Documentation/translations/zh_CN/process/coding-style.rst b/Documentation/translations/zh_CN/process/coding-style.rst
index b8c484a84d10..638d714bec83 100644
--- a/Documentation/translations/zh_CN/process/coding-style.rst
+++ b/Documentation/translations/zh_CN/process/coding-style.rst
@@ -268,8 +268,7 @@ C 程序员不使用类似 ThisVariableIsATemporaryCounter 这样华丽的名字
``count_active_users()`` 或者类似的名字,你不应该叫它 ``cntuser()`` 。

在函数名中包含函数类型 (所谓的匈牙利命名法) 是脑子出了问题——编译器知道那些类
-型而且能够检查那些类型,这样做只能把程序员弄糊涂了。难怪微软总是制造出有问题
-的程序。
+型而且能够检查那些类型,这样做只能把程序员弄糊涂了。

本地变量名应该简短,而且能够表达相关的含义。如果你有一些随机的整数型的循环计
数器,它应该被称为 ``i`` 。叫它 ``loop_counter`` 并无益处,如果它没有被误解的
--
2.32.0
\
 
 \ /
  Last update: 2021-07-03 19:00    [W:0.432 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site