lkml.org 
[lkml]   [2021]   [Jun]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 3/9] sections: Move and rename core_kernel_data() to is_kernel_data()
From
Date

On 2021/6/29 9:05, Steven Rostedt wrote:
> On Sat, 26 Jun 2021 15:34:33 +0800
> Kefeng Wang <wangkefeng.wang@huawei.com> wrote:
>
>> Move core_kernel_data() into sections.h and rename it to
>> is_kernel_data(), also make it return bool value, then
>> update all the callers.
> Removing the "core" part of "core_kernel_data()" is misleading. As
> modules can have kernel data, but this will return false on module data
> (as it should). This is similar to core_kernel_text() which this series
> doesn't seem to touch.

Yes, The series only collect and move the basic part(aka, the 'core'
part, which only

contains the start/end address check of sections) into
include/asm-generic/sections.h,

the core_kernel_text() contains system_state validation, it's not
inappropriate into sections.h,

so it won't be modified and moved.

>
> I'd like to keep the "core" in the name which makes it obvious this is
> not about module data, and if someone were to make it about module
> data, it will break ftrace synchronization.

After this series, we have 5 APIs, only use core_kernel_data() is a
little strange,

 * is_kernel_data()       --- come from core_kernel_data() in kernel.h
 * is_kernel_rodata()    --- already in sections.h
 * is_kernel_text()        --- come from kallsyms.h
 * is_kernel_inittext()   --- come from kernel.h and kallsyms.h
 * is_kernel()                --- come from kallsyms.h

Could we rename is_kernel_data() to is_kernel_core_data(), and add some
comment your mentioned,

or any better naming, thanks.

>
> -- Steve
> .
>

\
 
 \ /
  Last update: 2021-06-29 08:37    [W:0.149 / U:0.392 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site