lkml.org 
[lkml]   [2021]   [Jun]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH -next] btrfs: send: use list_move_tail instead of list_del/list_add_tail
From
Date
Thank you for your advice.

I'm about to send a patch v2 with the changes suggested by you.

Best Regards


在 2021/6/8 22:12, David Sterba 写道:
> On Tue, Jun 08, 2021 at 01:16:21PM +0800, Anand Jain wrote:
>> On 8/6/21 11:12 am, Baokun Li wrote:
>>> Using list_move_tail() instead of list_del() + list_add_tail().
>>>
>>> Reported-by: Hulk Robot <hulkci@huawei.com>
>>> Signed-off-by: Baokun Li <libaokun1@huawei.com>
>>> ---
>>> fs/btrfs/send.c | 3 +--
>>> 1 file changed, 1 insertion(+), 2 deletions(-)
>>>
>>> diff --git a/fs/btrfs/send.c b/fs/btrfs/send.c
>>> index bd69db72acc5..a0e51b2416a1 100644
>>> --- a/fs/btrfs/send.c
>>> +++ b/fs/btrfs/send.c
>>> @@ -2083,8 +2083,7 @@ static struct name_cache_entry *name_cache_search(struct send_ctx *sctx,
>>> */
>>> static void name_cache_used(struct send_ctx *sctx, struct name_cache_entry *nce)
>>> {
>>> - list_del(&nce->list);
>>> - list_add_tail(&nce->list, &sctx->name_cache_list);
>>> + list_move_tail(&nce->list, &sctx->name_cache_list);
>>> }
>>
>> Looks good.
>> You can consider open-code name_cache_used() as there is only one user.
> Yeah sounds like a good idea, with part of the function comment next to
> the list_move_tail.
> .

\
 
 \ /
  Last update: 2021-06-11 08:06    [W:0.066 / U:0.084 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site