lkml.org 
[lkml]   [2021]   [May]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 0/6] Don't use BIT() macro in UAPI headers
On Thu, May 20, 2021, Joe Richey wrote:
> From: Joe Richey <joerichey@google.com>
>
> The BIT(n) macro is used in the kernel as an alias for (1 << n).
> However, it is not defined in the UAPI headers, which means that any
> UAPI header files must be careful not to use it, or else the user
> will get a linker error. For example, compiling the following program:
>
> #include <sys/auxv.h>
> #include <asm/hwcap2.h>
>
> // Detect if FSGSBASE instructions are enabled
> int main() {
> unsigned long val = getauxval(AT_HWCAP2);
> return !(val & HWCAP2_FSGSBASE);
> }
>
> Results in the following likner error:
>
> /usr/bin/ld: /tmp/cceFpAdR.o: in function `main':
> gs.c:(.text+0x21): undefined reference to `BIT'
>
> This patch series changes all UAPI uses of BIT() to just be open-coded.
> However, there really should be a check for this in checkpatch.pl

Any reason not to provide such a patch in this series? :-)

> Currently, the script actually _encourages_ users to use the BIT macro
> even if adding things to UAPI.
>
> Running `rg "BIT\(" **/uapi/**` shows no more usage of BIT() in any
> UAPI headers. Tested by building a basic kernel. Changes are trivial.

\
 
 \ /
  Last update: 2021-05-20 17:48    [W:0.135 / U:0.220 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site