lkml.org 
[lkml]   [2021]   [Mar]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH 2/3] cpumask: Introduce DYING mask
On Sun, 21 Mar 2021 19:30:37 +0000
Qais Yousef <qais.yousef@arm.com> wrote:

> On 03/10/21 15:53, Peter Zijlstra wrote:
> > --- a/kernel/cpu.c
> > +++ b/kernel/cpu.c
> > @@ -160,6 +160,9 @@ static int cpuhp_invoke_callback(unsigne
> > int (*cb)(unsigned int cpu);
> > int ret, cnt;
> >
> > + if (bringup != !cpu_dying(cpu))
>
> nit: this condition is hard to read

Would
if (bringup == !!cpu_dying(cpu))

read better?

-- Steve

>
> > + set_cpu_dying(cpu, !bringup);
\
 
 \ /
  Last update: 2021-03-22 16:09    [W:0.127 / U:0.176 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site