lkml.org 
[lkml]   [2021]   [Mar]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH v3 00/11] gpio: implement the configfs testing module
    On Tue, Mar 09, 2021 at 09:59:10PM +0100, Bartosz Golaszewski wrote:
    > From: Bartosz Golaszewski <bgolaszewski@baylibre.com>
    >
    > This series adds a new GPIO testing module based on configfs committable items
    > and sysfs. The goal is to provide a testing driver that will be configurable
    > at runtime (won't need module reload) and easily extensible. The control over
    > the attributes is also much more fine-grained than in gpio-mockup.
    >
    > This series also contains a respin of the patches I sent separately to the
    > configfs maintainers - these patches implement the concept of committable
    > items that was well defined for a long time but never actually completed.
    >
    > Apart from the new driver itself, its selftests and the configfs patches, this
    > series contains some changes to the bitmap API - most importantly: it adds
    > devres managed variants of bitmap_alloc() and bitmap_zalloc().
    >
    > v1 -> v2:
    > - add selftests for gpio-sim
    > - add helper programs for selftests
    > - update the configfs rename callback to work with the new API introduced in
    > v5.11
    > - fix a missing quote in the documentation
    > - use !! whenever using bits operation that are required to return 0 or 1
    > - use provided bitmap API instead of reimplementing copy or fill operations
    > - fix a deadlock in gpio_sim_direction_output()
    > - add new read-only configfs attributes for mapping of configfs items to GPIO
    > device names
    > - and address other minor issues pointed out in reviews of v1
    >
    > v2 -> v3:
    > - use devm_bitmap_alloc() instead of the zalloc variant if we're initializing
    > the bitmap with 1s
    > - drop the patch exporting device_is_bound()
    > - don't return -ENODEV from dev_nam and chip_name configfs attributes, return
    > a string indicating that the device is not available yet ('n/a')
    > - fix indentation where it makes sense
    > - don't protect IDA functions which use their own locking and where it's not
    > needed
    > - use kmemdup() instead of kzalloc() + memcpy()
    > - collected review tags
    > - minor coding style fixes

    Thanks for dropping the device_is_bound() stuff, looks sane to me.

    greg k-h

    \
     
     \ /
      Last update: 2021-03-10 10:53    [W:4.805 / U:0.060 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site