lkml.org 
[lkml]   [2021]   [Mar]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v3 2/3] bus: mhi: core: Move to polling method to wait for MHI ready
From
Date
On 2/23/2021 8:44 PM, Bhaumik Bhatt wrote:
> In certain devices, it is likely that there is no incoming MHI
> interrupt for a transition to MHI READY state. One such example
> is the move from Pass Through to an SBL or AMSS execution
> environment. In order to facilitate faster bootup times as there
> is no need to wait until timeout_ms completes, MHI host can poll
> every 25 milliseconds to check if device has entered MHI READY
> until a maximum timeout of twice the timeout_ms is reached.
>
> Signed-off-by: Bhaumik Bhatt <bbhatt@codeaurora.org>
> ---
> drivers/bus/mhi/core/pm.c | 31 ++++++++++++++-----------------
> 1 file changed, 14 insertions(+), 17 deletions(-)
>
> diff --git a/drivers/bus/mhi/core/pm.c b/drivers/bus/mhi/core/pm.c
> index 681960c..5fe33d4 100644
> --- a/drivers/bus/mhi/core/pm.c
> +++ b/drivers/bus/mhi/core/pm.c
> @@ -153,34 +153,31 @@ static void mhi_toggle_dev_wake(struct mhi_controller *mhi_cntrl)
> /* Handle device ready state transition */
> int mhi_ready_state_transition(struct mhi_controller *mhi_cntrl)
> {
> - void __iomem *base = mhi_cntrl->regs;
> struct mhi_event *mhi_event;
> enum mhi_pm_state cur_state;
> struct device *dev = &mhi_cntrl->mhi_dev->dev;
> - u32 reset = 1, ready = 0;
> int ret, i;
>
> - /* Wait for RESET to be cleared and READY bit to be set by the device */
> - wait_event_timeout(mhi_cntrl->state_event,
> - MHI_PM_IN_FATAL_STATE(mhi_cntrl->pm_state) ||
> - mhi_read_reg_field(mhi_cntrl, base, MHICTRL,
> - MHICTRL_RESET_MASK,
> - MHICTRL_RESET_SHIFT, &reset) ||
> - mhi_read_reg_field(mhi_cntrl, base, MHISTATUS,
> - MHISTATUS_READY_MASK,
> - MHISTATUS_READY_SHIFT, &ready) ||
> - (!reset && ready),
> - msecs_to_jiffies(mhi_cntrl->timeout_ms));
> -
> /* Check if device entered error state */
> if (MHI_PM_IN_FATAL_STATE(mhi_cntrl->pm_state)) {
> dev_err(dev, "Device link is not accessible\n");
> return -EIO;
> }
>
> - /* Timeout if device did not transition to ready state */
> - if (reset || !ready) {
> - dev_err(dev, "Device Ready timeout\n");
> + /* Wait for RESET to be cleared and READY bit to be set by the device */
> + ret = mhi_poll_reg_field(mhi_cntrl, mhi_cntrl->regs, MHICTRL,
> + MHICTRL_RESET_MASK, MHICTRL_RESET_SHIFT, 0,
> + 25000);
> + if (ret) {
> + dev_err(dev, "Device failed to clear MHI Reset\n");
> + return -ETIMEDOUT;
> + }
> +
> + ret = mhi_poll_reg_field(mhi_cntrl, mhi_cntrl->regs, MHISTATUS,
> + MHISTATUS_READY_MASK, MHISTATUS_READY_SHIFT, 1,
> + 25000);

You use the magic number "25000" twice here. Its my understanding that
the preference is to inline a magic number if its used in one spot, but
use a macro if its used more than that.

Both uses are confined to this function, and in close proximity, so
chances that one gets updated without the other seem minimal, so this
feels like a borderline case. I don't know if Mani has an opinion here.

I'd probably err on the side of making a macro or a single variable. If
not, I think some comments explaining the value are warranted (should
comment the macro as well).

> + if (ret) {
> + dev_err(dev, "Device failed to enter MHI Ready\n");
> return -ETIMEDOUT;
> }
>
>


--
Jeffrey Hugo
Qualcomm Technologies, Inc. is a member of the
Code Aurora Forum, a Linux Foundation Collaborative Project.

\
 
 \ /
  Last update: 2021-03-10 20:04    [W:0.081 / U:1.228 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site