lkml.org 
[lkml]   [2021]   [Feb]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH mvebu v2 00/10] Armada 37xx: Fix cpufreq changing b ase CPU speed to 800 MHz from 1000 MHz


    On Tue, Feb 9, 2021, at 5:51 PM, nnet wrote:
    > On Tue, Feb 9, 2021, at 5:31 PM, nnet wrote:
    > > On Tue, Feb 9, 2021, at 3:26 PM, Marek Behún wrote:
    > > > On Tue, 09 Feb 2021 15:16:45 -0800
    > > > nnet <nnet@fastmail.fm> wrote:
    > > >
    > > > > I've two of these and I've just swapped them (and re-pasted the heat sinks).
    > > > >
    > > > > The second one ran under load for awhile and now has frozen as well.
    > > > >
    > > > > Under a moderate load `wget -O /dev/null <large.bin>` @X00Mbits they are fine.
    > > > >
    > > > > Under a 1 min speed test of load ~200Mbits routed WireGuard they freeze.
    > > > >
    > > > > They fine with both those workloads @1000_800.
    > > > >
    > > > > Perhaps it's heat? Unfortunately I don't have any numbers on that ATM.
    > > >
    > > > Try disabling cpufreq in kernel completely, compile boot image at
    > > > 1200 MHz. If it continues freezing, then I fear we can't help you with
    > > > 1200 MHz :(
    > >
    > > cat /sys/devices/system/cpu/cpufreq/policy0/scaling_available_frequencies
    > > 200000 300000 600000 1200000
    > >
    > > I'm not getting any freezes with 1.2GHz fixed after 20 minutes of load:
    > >
    > > echo 1200000 > /sys/devices/system/cpu/cpufreq/policy0/scaling_min_freq
    > >
    > > Setting it back to min 200MHz I get a freeze within a minute:
    > >
    > > echo 200000 > /sys/devices/system/cpu/cpufreq/policy0/scaling_min_freq
    > >
    > > > Marek
    > > >
    >
    > > +#define MIN_VOLT_MV_FOR_L0_L1_1GHZ 1108
    >
    > Based on the below at boot time might an equivalent of the above need
    > to be 1225 for 1.2GHz?
    >
    > 1200_750
    > SVC REV: 5, CPU VDD voltage: 1.225V
    >
    > 1000_800
    > SVC REV: 5, CPU VDD voltage: 1.108V

    I did this for a quick test for 1.2GHz:

    +#define MIN_VOLT_MV_FOR_L0_L1_1GHZ 1225

    This is working well so far. Frequency is shifting up/down with load applied/stopped.

    \
     
     \ /
      Last update: 2021-02-10 03:33    [W:4.187 / U:0.964 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site