lkml.org 
[lkml]   [2021]   [Feb]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v4 2/4] lib: vsprintf: Fix handling of number field widths in vsscanf
From
Date
On 04/02/2021 16:35, Petr Mladek wrote:
> On Wed 2021-02-03 21:45:55, Andy Shevchenko wrote:
>> On Wed, Feb 03, 2021 at 04:50:07PM +0000, Richard Fitzgerald wrote:
>>> The existing code attempted to handle numbers by doing a strto[u]l(),
>>> ignoring the field width, and then repeatedly dividing to extract the
>>> field out of the full converted value. If the string contains a run of
>>> valid digits longer than will fit in a long or long long, this would
>>> overflow and no amount of dividing can recover the correct value.
>
>> ...
>>
>>> + for (; max_chars > 0; max_chars--) {
>>
>> Less fragile is to write
>>
>> while (max_chars--)
>
> Except that the original was more obvious at least for me.
> I always prefer more readable code when the compiler might do
> the optimization easily. But this is my personal taste.
> I am fine with both variants.
>
>>
>> This allows max_char to be an unsigned type.
>>
>> Moreover...
>>
>>> + return _parse_integer_limit(s, base, p, INT_MAX);
>>
>> You have inconsistency with INT_MAX vs, size_t above.
>
> Ah, this was on my request. INT_MAX is already used on many other
> locations in vsnprintf() for this purpose.
>

Strictly speaking this should be SIZE_MAX because the argument is a
size_t.

\
 
 \ /
  Last update: 2021-02-08 13:11    [W:0.074 / U:0.156 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site