lkml.org 
[lkml]   [2021]   [Feb]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] mm/list_lru.c: remove kvfree_rcu_local()
From
Date
On 07.02.2021 18:21, Shakeel Butt wrote:
> The list_lru file used to have local kvfree_rcu() which was renamed by
> commit e0feed08ab41 ("mm/list_lru.c: Rename kvfree_rcu() to local
> variant") to introduce the globally visible kvfree_rcu(). Now we have
> global kvfree_rcu(), so remove the local kvfree_rcu_local() and just
> use the global one.
>
> Signed-off-by: Shakeel Butt <shakeelb@google.com>

Reviewed-by: Kirill Tkhai <ktkhai@virtuozzo.com>

> ---
> mm/list_lru.c | 12 ++----------
> 1 file changed, 2 insertions(+), 10 deletions(-)
>
> diff --git a/mm/list_lru.c b/mm/list_lru.c
> index fe230081690b..6f067b6b935f 100644
> --- a/mm/list_lru.c
> +++ b/mm/list_lru.c
> @@ -373,21 +373,13 @@ static void memcg_destroy_list_lru_node(struct list_lru_node *nlru)
> struct list_lru_memcg *memcg_lrus;
> /*
> * This is called when shrinker has already been unregistered,
> - * and nobody can use it. So, there is no need to use kvfree_rcu_local().
> + * and nobody can use it. So, there is no need to use kvfree_rcu().
> */
> memcg_lrus = rcu_dereference_protected(nlru->memcg_lrus, true);
> __memcg_destroy_list_lru_node(memcg_lrus, 0, memcg_nr_cache_ids);
> kvfree(memcg_lrus);
> }
>
> -static void kvfree_rcu_local(struct rcu_head *head)
> -{
> - struct list_lru_memcg *mlru;
> -
> - mlru = container_of(head, struct list_lru_memcg, rcu);
> - kvfree(mlru);
> -}
> -
> static int memcg_update_list_lru_node(struct list_lru_node *nlru,
> int old_size, int new_size)
> {
> @@ -419,7 +411,7 @@ static int memcg_update_list_lru_node(struct list_lru_node *nlru,
> rcu_assign_pointer(nlru->memcg_lrus, new);
> spin_unlock_irq(&nlru->lock);
>
> - call_rcu(&old->rcu, kvfree_rcu_local);
> + kvfree_rcu(old, rcu);
> return 0;
> }
>
>

\
 
 \ /
  Last update: 2021-02-08 19:33    [W:0.064 / U:0.212 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site