lkml.org 
[lkml]   [2021]   [Feb]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 1/2] docs: Make syscalls' helpers naming consistent
Date
André Almeida <andrealmeid@collabora.com> writes:

> The documentation explains the need to create internal syscalls' helpers,
> and that they should be called `kern_xyzzy()`. However, the comment at
> include/linux/syscall.h says that they should be named as
> `ksys_xyzzy()`, and so are all the helpers declared bellow it. Change the
> documentation to reflect this.
>
> Cc: Dominik Brodowski <linux@dominikbrodowski.net>
> Fixes: 819671ff849b ("syscalls: define and explain goal to not call syscalls in the kernel")
> Signed-off-by: André Almeida <andrealmeid@collabora.com>
> ---
> Documentation/process/adding-syscalls.rst | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)

I've applied both patches thanks (also did s/syscall.h/syscalls.h in the
above changelog).

jon

\
 
 \ /
  Last update: 2021-02-04 22:51    [W:0.077 / U:0.624 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site