lkml.org 
[lkml]   [2021]   [Feb]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH] x86: Add a prompt for HPET_EMULATE_RTC
> >
> > Hi,
> >
> > On plain vanilla 5.11-rc6, when I take this (partial) .config file
> > which contains:
> >
> > CONFIG_HPET=y
> > # CONFIG_HPET_EMULATE_RTC is not set
> > # CONFIG_HPET_MMAP is not set
> >
> > and run
> > $ make olddefconfig
> >
> > my new .config file contains
> >
> > CONFIG_HPET_TIMER=y
> > CONFIG_HPET_EMULATE_RTC=y
> > CONFIG_HPET=y
> > # CONFIG_HPET_MMAP is not set
> >
> >
> > Isn't that what you are expecting?
> > or are you trying to keep the opposite?
> >
> > # CONFIG_HPET_EMULATE_RTC is not set
> >
> > Hm, I bet that I misunderstood you and you want to keep
> > it disabled. Is that right?

Yes, I want to keep it disabled. My understanding (from the behaviour
I've seen with other settings, as well as reading the sources) is that
"is not set" is treated the same as "n".

In fact, if you change the old config to CONFIG_HPET_EMULATE_RTC=n,
you get the same before/after behaviour of this patch. Before,
olddefconfig will ignore the old setting and change it to "y". With
this patch, olddefconfig keeps the old setting, but re-writes it to
"is not set". This is even more surprising because the user is
explicit in what the old config setting is, but olddefconfig still
ignores it.

>
> If that's the case, then I agree that your original patch to
> make HPET_EMULATE_RTC user-visible is needed.
>
> Sorry to be so slow about understanding your goal (if I do
> understand it now).
>
> --
> ~Randy
>


--
Anand K. Mistry
Software Engineer
Google Australia

\
 
 \ /
  Last update: 2021-02-04 21:56    [W:0.037 / U:0.336 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site