lkml.org 
[lkml]   [2021]   [Feb]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH 4/4] hugetlb: Do early cow when page pinned on src mm
On Wed, Feb 3, 2021 at 1:08 PM Peter Xu <peterx@redhat.com> wrote:
>
> This is the last missing piece of the COW-during-fork effort when there're
> pinned pages found. One can reference 70e806e4e645 ("mm: Do early cow for
> pinned pages during fork() for ptes", 2020-09-27) for more information, since
> we do similar things here rather than pte this time, but just for hugetlb.

No issues with the code itself, but..

Comments are good, but the comments inside this block of code actually
makes the code *much* harder to read, because now the actual logic is
much more spread out and you can't see what it does so well.

> + if (unlikely(page_needs_cow_for_dma(vma, ptepage))) {
> + /* This is very possibly a pinned huge page */
> + if (!prealloc) {
> + /*
> + * Preallocate the huge page without
> + * tons of locks since we could sleep.
> + * Note: we can't use any reservation
> + * because the page will be exclusively
> + * owned by the child later.
> + */
> + put_page(ptepage);
> + spin_unlock(src_ptl);
> + spin_unlock(dst_ptl);
> + prealloc = alloc_huge_page(vma, addr, 0);
> + if (!prealloc) {
> + /*
> + * hugetlb_cow() seems to be
> + * more careful here than us.
> + * However for fork() we could
> + * be strict not only because
> + * no one should be referencing
> + * the child mm yet, but also
> + * if resources are rare we'd
> + * better simply fail the
> + * fork() even earlier.
> + */
> + ret = -ENOMEM;
> + break;
> + }
> + goto again;
> + }
> + /*
> + * We have page preallocated so that we can do
> + * the copy right now.
> + */
> + hugetlb_copy_page(vma, dst_pte, addr, ptepage,
> + prealloc);
> + put_page(ptepage);
> + spin_unlock(src_ptl);
> + spin_unlock(dst_ptl);
> + prealloc = NULL;
> + continue;
> + }

Can you move the comment above the code? And I _think_ the prealloc
conditional could be split up to a helper function (which would help
more), but maybe there are too many variables for that to be
practical.

Linus

\
 
 \ /
  Last update: 2021-02-03 22:17    [W:0.249 / U:0.304 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site