lkml.org 
[lkml]   [2021]   [Feb]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v8 12/22] counter: Rename counter_count_function to counter_function
On Sat, Feb 20, 2021 at 10:56:13AM -0600, David Lechner wrote:
> On 2/14/21 11:13 AM, Jonathan Cameron wrote:
> > On Fri, 12 Feb 2021 21:13:36 +0900
> > William Breathitt Gray <vilhelm.gray@gmail.com> wrote:
> >
> >> The phrase "Counter Count function" is verbose and unintentionally
> >> implies that function is a Count extension. This patch adjusts the
> >> Counter subsystem code to use the more direct "Counter function" phrase
> >> to make the intent of this code clearer. The phrase "Count action" is
> >> adjusted herein as well for the same reason.
> >>
> >> Cc: Syed Nayyar Waris <syednwaris@gmail.com>
> >> Cc: Patrick Havelange <patrick.havelange@essensium.com>
> >> Cc: Kamel Bouhara <kamel.bouhara@bootlin.com>
> >> Cc: Fabrice Gasnier <fabrice.gasnier@st.com>
> >> Cc: Maxime Coquelin <mcoquelin.stm32@gmail.com>
> >> Cc: Alexandre Torgue <alexandre.torgue@st.com>
> >> Cc: David Lechner <david@lechnology.com>
> >> Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
> >
> > I agree this makes sense in the counter core code, but in the drivers
> > it may not be quite so obvious we are talking about a counter function
> > given some of the bits of hardware do a number of other things.
> >
> > I guess up to the various driver maintainers on whether they
> > think the new meaning is clear enough!
> >
> > Jonathan
> >
>
> TBH, I think "counter count function" makes more sense to me.

That's a fair point. I'll revert this for the individual drivers and
leave it up to the maintainers if they want to adjust their namings.
Instead, I'll limit the name changes to the counter core code.

William Breathitt Gray

[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2021-02-23 06:16    [W:0.068 / U:40.948 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site