[lkml]   [2021]   [Feb]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 18/18] arm64: apple: Add initial Mac Mini 2020 (M1) devicetree
* Hector Martin 'marcan' <> [210208 12:05]:
> On 08/02/2021 20.04, Krzysztof Kozlowski wrote:

> > > + clk24: clk24 {
> >
> > Just "clock". Node names should be generic.
> Really? Almost every other device device tree uses unique clock node names.

Yeah please just use generic node name "clock". FYI, we're still hurting
because of this for the TI clock node names years after because the drivers
got a chance to rely on the clock node name..

Using "clock" means your clock driver code won't get a chance to wrongly
use the node name and you avoid similar issues.



 \ /
  Last update: 2021-02-10 11:32    [W:0.183 / U:0.732 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site