lkml.org 
[lkml]   [2021]   [Dec]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] xen-blkfront: Use the bitmap API when applicable
From
Date
On 01.12.21 22:10, Christophe JAILLET wrote:
> Use 'bitmap_zalloc()' to simplify code, improve the semantic and avoid some
> open-coded arithmetic in allocator arguments.
>
> Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
> consistency.
>
> Use 'bitmap_copy()' to avoid an explicit 'memcpy()'
>
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> ---
> drivers/block/xen-blkfront.c | 8 +++-----
> 1 file changed, 3 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/block/xen-blkfront.c b/drivers/block/xen-blkfront.c
> index 700c765a759a..fe4d69cf9469 100644
> --- a/drivers/block/xen-blkfront.c
> +++ b/drivers/block/xen-blkfront.c
> @@ -442,16 +442,14 @@ static int xlbd_reserve_minors(unsigned int minor, unsigned int nr)
> if (end > nr_minors) {
> unsigned long *bitmap, *old;
>
> - bitmap = kcalloc(BITS_TO_LONGS(end), sizeof(*bitmap),
> - GFP_KERNEL);
> + bitmap = bitmap_zalloc(end, GFP_KERNEL);
> if (bitmap == NULL)
> return -ENOMEM;
>
> spin_lock(&minor_lock);
> if (end > nr_minors) {
> old = minors;
> - memcpy(bitmap, minors,
> - BITS_TO_LONGS(nr_minors) * sizeof(*bitmap));
> + bitmap_copy(bitmap, minors, nr_minors);
> minors = bitmap;
> nr_minors = BITS_TO_LONGS(end) * BITS_PER_LONG;
> } else

Shouldn't you use bitmap_free(old) some lines down?

> @@ -2610,7 +2608,7 @@ static void __exit xlblk_exit(void)
>
> xenbus_unregister_driver(&blkfront_driver);
> unregister_blkdev(XENVBD_MAJOR, DEV_NAME);
> - kfree(minors);
> + bitmap_free(minors);
> }
> module_exit(xlblk_exit);


Juergen

[unhandled content-type:application/pgp-keys][unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2021-12-02 07:13    [W:0.305 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site