lkml.org 
[lkml]   [2021]   [Nov]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 00/31] kasan, vmalloc, arm64: add vmalloc tagging support for SW/HW_TAGS
Date
From: Andrey Konovalov <andreyknvl@google.com>

Hi,

This patchset adds vmalloc tagging support for SW_TAGS and HW_TAGS
KASAN modes.

About half of patches are cleanups I went for along the way. None of
them seem to be important enough to go through stable, so I decided
not to split them out into separate patches/series.

I'll keep the patchset based on the mainline for now. Once the
high-level issues are resolved, I'll rebase onto mm - there might be
a few conflicts right now.

The patchset is partially based on an early version of the HW_TAGS
patchset by Vincenzo that had vmalloc support. Thus, I added a
Co-developed-by tag into a few patches.

SW_TAGS vmalloc tagging support is straightforward. It reuses all of
the generic KASAN machinery, but uses shadow memory to store tags
instead of magic values. Naturally, vmalloc tagging requires adding
a few kasan_reset_tag() annotations to the vmalloc code.

HW_TAGS vmalloc tagging support stands out. HW_TAGS KASAN is based on
Arm MTE, which can only assigns tags to physical memory. As a result,
HW_TAGS KASAN only tags vmalloc() allocations, which are backed by
page_alloc memory. It ignores vmap() and others.

Two things about the patchset that might be questionable, and I'd like
to get input on:

1. In this version of the pathset, if both HW_TAGS KASAN and memory
initialization are enabled, the memory for vmalloc() allocations is
initialized by page_alloc, while the tags are assigned in vmalloc.
Initially I thought that moving memory initialization into vmalloc
would be confusing, but I don't have any good arguments to support
that. So unless anyone has objecttions, I will move memory
initialization for HW_TAGS KASAN into vmalloc in v2.

2. In this version of the patchset, when VMAP_STACK is enabled, pointer
tags of stacks allocated via vmalloc() are reset, see the "kasan,
fork: don't tag stacks allocated with vmalloc" patch. However,
allowing sp to be tagged works just fine in my testing setup. Does
anyone has an idea of why having a tagged sp in the kernel could be
bad? If not, I can drop the mentioned patch.

Thanks!

Andrey Konovalov (31):
kasan, page_alloc: deduplicate should_skip_kasan_poison
kasan, page_alloc: move tag_clear_highpage out of
kernel_init_free_pages
kasan, page_alloc: merge kasan_free_pages into free_pages_prepare
kasan, page_alloc: simplify kasan_poison_pages call site
kasan, page_alloc: init memory of skipped pages on free
mm: clarify __GFP_ZEROTAGS comment
kasan: only apply __GFP_ZEROTAGS when memory is zeroed
kasan, page_alloc: refactor init checks in post_alloc_hook
kasan, page_alloc: merge kasan_alloc_pages into post_alloc_hook
kasan, page_alloc: combine tag_clear_highpage calls in post_alloc_hook
kasan, page_alloc: move SetPageSkipKASanPoison in post_alloc_hook
kasan, page_alloc: move kernel_init_free_pages in post_alloc_hook
kasan, page_alloc: simplify kasan_unpoison_pages call site
kasan: clean up metadata byte definitions
kasan: define KASAN_VMALLOC_INVALID for SW_TAGS
kasan, x86, arm64, s390: rename functions for modules shadow
kasan, vmalloc: drop outdated VM_KASAN comment
kasan: reorder vmalloc hooks
kasan: add wrappers for vmalloc hooks
kasan, vmalloc: reset tags in vmalloc functions
kasan, fork: don't tag stacks allocated with vmalloc
kasan, vmalloc: add vmalloc support to SW_TAGS
kasan, arm64: allow KASAN_VMALLOC with SW_TAGS
kasan, vmalloc, arm64: mark vmalloc mappings as pgprot_tagged
kasan, vmalloc: don't unpoison VM_ALLOC pages before mapping
kasan, page_alloc: allow skipping unpoisoning for HW_TAGS
kasan, vmalloc: add vmalloc support to HW_TAGS
kasan: add kasan.vmalloc command line flag
kasan, arm64: allow KASAN_VMALLOC with HW_TAGS
kasan: documentation updates
kasan: improve vmalloc tests

Documentation/dev-tools/kasan.rst | 17 ++-
arch/arm64/Kconfig | 2 +-
arch/arm64/include/asm/vmalloc.h | 10 ++
arch/arm64/kernel/module.c | 2 +-
arch/s390/kernel/module.c | 2 +-
arch/x86/kernel/module.c | 2 +-
include/linux/gfp.h | 17 ++-
include/linux/kasan.h | 90 +++++++++------
include/linux/vmalloc.h | 18 ++-
kernel/fork.c | 1 +
lib/Kconfig.kasan | 20 ++--
lib/test_kasan.c | 181 +++++++++++++++++++++++++++++-
mm/kasan/common.c | 4 +-
mm/kasan/hw_tags.c | 142 +++++++++++++++++++----
mm/kasan/kasan.h | 16 ++-
mm/kasan/shadow.c | 54 +++++----
mm/page_alloc.c | 138 +++++++++++++++--------
mm/vmalloc.c | 65 +++++++++--
18 files changed, 597 insertions(+), 184 deletions(-)

--
2.25.1

\
 
 \ /
  Last update: 2021-11-30 22:41    [W:0.231 / U:0.356 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site