lkml.org 
[lkml]   [2021]   [Oct]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH] btrfs: Simplify conditional in assert
Date
On 15/10/2021 12:52, David Sterba wrote:
> Adding Johannes to CC,
>
> On Fri, Oct 15, 2021 at 06:36:39AM -0400, Wan Jiabing wrote:
>> Fix following coccicheck warning:
>> ./fs/btrfs/inode.c:2015:16-18: WARNING !A || A && B is equivalent to !A || B
>>
>> Signed-off-by: Wan Jiabing <wanjiabing@vivo.com>
>> ---
>> fs/btrfs/inode.c | 3 +--
>> 1 file changed, 1 insertion(+), 2 deletions(-)
>>
>> diff --git a/fs/btrfs/inode.c b/fs/btrfs/inode.c
>> index e9154b436c47..da4aeef73b0d 100644
>> --- a/fs/btrfs/inode.c
>> +++ b/fs/btrfs/inode.c
>> @@ -2011,8 +2011,7 @@ int btrfs_run_delalloc_range(struct btrfs_inode *inode, struct page *locked_page
>> * to use run_delalloc_nocow() here, like for regular
>> * preallocated inodes.
>> */
>> - ASSERT(!zoned ||
>> - (zoned && btrfs_is_data_reloc_root(inode->root)));
>> + ASSERT(!zoned || btrfs_is_data_reloc_root(inode->root));
>
> The short form is equivalent, but I'm not sure it's also on the same
> level of readability. Repeating the 'zoned' condition check makes it
> obvious on first sight, which is what I'd prefer.
>
> Johannes if you'd like the new version I'll change it but otherwise I'm
> fine with what we have now.

I'm fine either way, no strong preferences from my side.


\
 
 \ /
  Last update: 2021-10-15 13:42    [W:0.072 / U:0.096 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site