lkml.org 
[lkml]   [2021]   [Oct]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [sched.h] 317419b91e: perf-sanity-tests.Parse_sched_tracepoints_fields.fail
On Fri, Oct 15, 2021 at 10:14 AM Steven Rostedt <rostedt@goodmis.org> wrote:
>
> On Fri, 15 Oct 2021 10:05:56 +0800
> Yafang Shao <laoar.shao@gmail.com> wrote:
>
> > > I'd say we need a TASK_COMM_LEN_V1 to use in all the old hard-coded
> > > places.
> > >
> >
> > Sure, it will be easy to grep then.
>
> Just because I'm picky about my bikeshed colors...
>
>
> Perhaps have it called TASK_COMM_LEN_16 ?
>
> The reason being, I have no idea what "V1" is. Version 1? What's that
> mean? And now TASK_COMM_LEN can be either 16 or 24. Perhaps we can have
> it be:
>
> #define TASK_COMM_LEN_16 16
> #define TASK_COMM_LEN_24 24
>
> if CONFIG_BASE_SMALL
> #define TASK_COMM_LEN TASK_COMM_LEN_16
> #else
> #define TASK_COMM_LEN TASK_COMM_LEN_24
> #endif
>
> or call it TASK_COMM_LEN_SMALL and TASK_COMM_LEN_LARGE
>
> ??
>
> It's still "grepable"
>

Good idea.

It seems TASK_COMM_LEN_16 and TASK_COMM_LEN_24 are more clear.
I will do it as you suggested.

--
Thanks
Yafang

\
 
 \ /
  Last update: 2021-10-15 04:22    [W:0.136 / U:6.676 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site