Messages in this thread |  | | Date | Mon, 4 Jan 2021 12:45:58 +0900 | | From | Masami Hiramatsu <> | | Subject | Re: [PATCH -tip v2] x86/kprobes: Do not decode opcode in resume_execution() |
| |
On Thu, 31 Dec 2020 17:09:23 +0100 Borislav Petkov <bp@alien8.de> wrote:
> On Fri, Dec 18, 2020 at 11:12:05PM +0900, Masami Hiramatsu wrote: > > @@ -467,8 +489,8 @@ static int arch_copy_kprobe(struct kprobe *p) > > */ > > len = prepare_boost(buf, p, &insn); > > > > - /* Check whether the instruction modifies Interrupt Flag or not */ > > - p->ainsn.if_modifier = is_IF_modifier(buf); > > + /* Analyze the opcode and set resume flags */ > > + set_resume_flags(p, &insn); > > So this function wants to be called something like analyze_insn() or so > then? set_resume_flags() is kinda misleading as a name.
Hrm, I meant setting the flags used in the resume_execution() afterwards. Since the instruction itself (not only opcode but also oprands) was also analyzed in other places, so I like the set_resume_flags() for it.
Thank you,
-- Masami Hiramatsu <mhiramat@kernel.org>
|  |