lkml.org 
[lkml]   [2021]   [Jan]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 10/24] kvm: x86/mmu: Factor out handle disconnected pt
Spell out "page tables"?  Not short on chars.  The grammar is also a bit funky.

KVM: x86/mmu: Factor out handling of disconnected page tables

On Tue, Jan 12, 2021, Ben Gardon wrote:
> Factor out the code to handle a disconnected subtree of the TDP paging
> structure from the code to handle the change to an individual SPTE.
> Future commits will build on this to allow asynchronous page freeing.
>
> No functional change intended.
>
> Reviewed-by: Peter Feiner <pfeiner@google.com>
>
> Signed-off-by: Ben Gardon <bgardon@google.com>
> ---
> arch/x86/kvm/mmu/tdp_mmu.c | 75 +++++++++++++++++++++++---------------
> 1 file changed, 46 insertions(+), 29 deletions(-)
>
> diff --git a/arch/x86/kvm/mmu/tdp_mmu.c b/arch/x86/kvm/mmu/tdp_mmu.c
> index 55df596696c7..e8f35cd46b4c 100644
> --- a/arch/x86/kvm/mmu/tdp_mmu.c
> +++ b/arch/x86/kvm/mmu/tdp_mmu.c
> @@ -234,6 +234,49 @@ static void handle_changed_spte_dirty_log(struct kvm *kvm, int as_id, gfn_t gfn,
> }
> }
>
> +/**
> + * handle_disconnected_tdp_mmu_page - handle a pt removed from the TDP structure

Maybe s/disconnected/removed?

I completely understand why you used "disconnected", and to a large extent I
agree it's a good descriptor, but all of the surrounding comments talk about the
page tables being "removed". And for me, "disconnected" implies that that it
could be reconnected in the future, whereas "removed" is a more firm "this page,
in its current form, is gone for good".

> + *
> + * @kvm: kvm instance
> + * @pt: the page removed from the paging structure
> + *
> + * Given a page table that has been removed from the TDP paging structure,
> + * iterates through the page table to clear SPTEs and free child page tables.
> + */
> +static void handle_disconnected_tdp_mmu_page(struct kvm *kvm, u64 *pt)
> +{
> + struct kvm_mmu_page *sp;
> + gfn_t gfn;
> + int level;
> + u64 old_child_spte;
> + int i;

Nit: use reverse fir tree? I don't think KVM needs to be as strict as tip for
that rule/guideline, but I do think it's usually a net positive for readability.

> + sp = sptep_to_sp(pt);
> + gfn = sp->gfn;
> + level = sp->role.level;

Initialize these from the get-go? That would held the reader understand these
are local snapshots to shorten lines, as opposed to scratch variables.

struct kvm_mmu_page *sp = sptep_to_sp(pt);
int level = sp->role.level;
gfn_t gfn = sp->gfn;
u64 old_child_spte;
int i;

> +
> + trace_kvm_mmu_prepare_zap_page(sp);
> +
> + list_del(&sp->link);
> +
> + if (sp->lpage_disallowed)
> + unaccount_huge_nx_page(kvm, sp);
> +
> + for (i = 0; i < PT64_ENT_PER_PAGE; i++) {
> + old_child_spte = READ_ONCE(*(pt + i));
> + WRITE_ONCE(*(pt + i), 0);
> + handle_changed_spte(kvm, kvm_mmu_page_as_id(sp),
> + gfn + (i * KVM_PAGES_PER_HPAGE(level - 1)),
> + old_child_spte, 0, level - 1);
> + }
> +
> + kvm_flush_remote_tlbs_with_address(kvm, gfn,
> + KVM_PAGES_PER_HPAGE(level));
> +
> + free_page((unsigned long)pt);
> + kmem_cache_free(mmu_page_header_cache, sp);
> +}

\
 
 \ /
  Last update: 2021-01-20 21:34    [W:0.385 / U:1.828 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site