lkml.org 
[lkml]   [2021]   [Jan]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] ACPI: configfs: add missing check after configfs_register_default_group
From
Date
On 2021/1/13 15:30, Qinglang Miao wrote:
> A list_add corruption is reported by Hulk Robot like this:
> ==============
> list_add corruption.
> Call Trace:
> link_obj+0xc0/0x1c0
> link_group+0x21/0x140
> configfs_register_subsystem+0xdb/0x380
> acpi_configfs_init+0x25/0x1000 [acpi_configfs]
> do_one_initcall+0x149/0x820
> do_init_module+0x1ef/0x720
> load_module+0x35c8/0x4380
> __do_sys_finit_module+0x10d/0x1a0
> do_syscall_64+0x34/0x80
>
> It's because of the missing check after configfs_register_default_group,
> where configfs_unregister_subsystem should be called once failure.

I think it's right to call *_unregister_* for error path, but...

>
> Fixes: 612bd01fc6e0 ("ACPI: add support for loading SSDTs via configfs")
> Reported-by: Hulk Robot <hulkci@huawei.com>
> Signed-off-by: Qinglang Miao <miaoqinglang@huawei.com>
> ---
> drivers/acpi/acpi_configfs.c | 7 ++++++-
> 1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/acpi/acpi_configfs.c b/drivers/acpi/acpi_configfs.c
> index cf91f4910..25512ab0e 100644
> --- a/drivers/acpi/acpi_configfs.c
> +++ b/drivers/acpi/acpi_configfs.c
> @@ -268,7 +268,12 @@ static int __init acpi_configfs_init(void)
>
> acpi_table_group = configfs_register_default_group(root, "table",
> &acpi_tables_type);
> - return PTR_ERR_OR_ZERO(acpi_table_group);
> + if (IS_ERR(acpi_table_group)) {
> + configfs_register_subsystem(&acpi_configfs);

...

Typo here, s/register/unregister.

Thanks
Hanjun

\
 
 \ /
  Last update: 2021-01-13 09:35    [W:0.029 / U:0.568 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site