lkml.org 
[lkml]   [2020]   [Sep]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2] of: address: Work around missing device_type property in pcie nodes
Hi Bjorn,

On 2020-09-30 17:51:54 -0500, Bjorn Helgaas wrote:
> On Wed, Sep 30, 2020 at 03:34:10PM -0500, Rob Herring wrote:
> > On Wed, Sep 30, 2020 at 12:37 PM Niklas Söderlund
> > <niklas.soderlund@ragnatech.se> wrote:
> > >
> > > Hi Marc,
> > >
> > > On 2020-09-30 18:23:21 +0100, Marc Zyngier wrote:
> > > > Hi Niklas,
> > > >
> > > > [+ Samuel]
> > > >
> > > > On 2020-09-30 17:27, Niklas Söderlund wrote:
> > > > > Hi Marc,
> > > > >
> > > > > I'm afraid this commit breaks booting my rk3399 device.
> > > > >
> > > > > I bisected the problem to this patch merged as [1]. I'm testing on a
> > > > > Scarlet device and I'm using the unmodified upstream
> > > > > rk3399-gru-scarlet-inx.dtb for my tests.
> > > > >
> > > > > The problem I'm experience is a black screen after the bootloader and
> > > > > the device is none responsive over the network. I have no serial console
> > > > > to this device so I'm afraid I can't tell you if there is anything
> > > > > useful on to aid debugging there.
> > > > >
> > > > > If I try to test one commit earlier [2] the system boots as expected and
> > > > > everything works as it did for me in v5.8 and earlier. I have worked
> > > > > little with this device and have no clue about what is really on the PCI
> > > > > buss. But running from [2] I have this info about PCI if it's helpful,
> > > > > please ask if somethings missing.
> > > >
> > > > Please see the thread at [1]. The problem was reported a few weeks back
> > > > by Samuel, and I was expecting Rob and Lorenzo to push a fix for this.
> > >
> > > Thanks for providing a solution.
> > >
> > > >
> > > > Rob, Lorenzo, any update on this?
> >
> > The fix is in Bjorn's tree[1].
> >
> > Bjorn, going to send this to Linus before v5.9 is out?
>
> Definitely, thanks for the reminder. I'm assuming the fix in question
> is https://git.kernel.org/pub/scm/linux/kernel/git/helgaas/pci.git/commit/?h=for-linus&id=e338eecf3fe79054e8a31b8c39a1234b5acfdabe

That patch solves my boot problem.

Cherry-picked and tested directly on-top of v5.9-rc7 (which fails to
boot without the patch in question).

>
> > [1] https://git.kernel.org/pub/scm/linux/kernel/git/helgaas/pci.git/log/?h=for-linus

--
Regards,
Niklas Söderlund

\
 
 \ /
  Last update: 2020-10-01 01:49    [W:0.034 / U:1.988 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site