lkml.org 
[lkml]   [2020]   [Sep]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v8 0/6] Support running driver's probe for a device powered off
On Sun, Sep 27, 2020 at 9:44 PM Tomasz Figa <tfiga@chromium.org> wrote:
>
> On Sun, Sep 27, 2020 at 9:39 PM Wolfram Sang <wsa@the-dreams.de> wrote:
> >
> >
> > > I think we might be overly complicating things. IMHO the series as is
> > > with the "i2c_" prefix removed from the flags introduced would be
> > > reusable as is for any other subsystem that needs it. Of course, for
> > > now, the handling of the flag would remain implemented only in the I2C
> > > subsystem.
> >
> > Just to be clear: you are suggesting to remove "i2c" from the DSD
> > binding "i2c-allow-low-power-probe". And you are not talking about
> > moving I2C_DRV_FL_ALLOW_LOW_POWER_PROBE to struct device_driver? I
> > recall the latter has been NACKed by gkh so far.
> >
>
> I'd also drop "I2C_" from "I2C_DRV_FL_ALLOW_LOW_POWER_PROBE", but all
> the implementation would remain where it is in the code. IOW, I'm just
> suggesting a naming change to avoid proliferating duplicate flags of
> the same meaning across subsystems.

But that would indicate that the property was recognized by other
subsystems which wouldn't be the case, so it would be confusing.

That's why it cannot be documented as a general property ATM too.

\
 
 \ /
  Last update: 2020-09-28 16:19    [W:0.061 / U:1.200 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site