lkml.org 
[lkml]   [2020]   [Sep]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
SubjectRe: [PATCH drm/hisilicon 2/3] drm/hisilicon: Features to support reading resolutions from EDID
From
Date
Hi

Am 21.09.20 um 05:25 schrieb Tian Tao:
> Use drm_get_edid to get the resolution, if that fails, set it to
> a fixed resolution.
>
> Signed-off-by: Tian Tao <tiantao6@hisilicon.com>
> ---
> drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_vdac.c | 35 ++++++++++++++++++++----
> 1 file changed, 29 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_vdac.c b/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_vdac.c
> index 376a05d..e84d381 100644
> --- a/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_vdac.c
> +++ b/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_vdac.c
> @@ -20,13 +20,24 @@
>
> static int hibmc_connector_get_modes(struct drm_connector *connector)
> {
> - int count;
> + int count = 0;
> + void *edid;
> + struct hibmc_connector *hibmc_connector = to_hibmc_connector(connector);
> +
> + edid = drm_get_edid(connector, &hibmc_connector->adapter);
> + if (edid) {
> + drm_connector_update_edid_property(connector, edid);
> + count = drm_add_edid_modes(connector, edid);

There's nothing wrong here, but i think it might be more readable if you do

if (count)
goto out;

within this branch. The out label would be just before the kfree. With
this change, the code with drm_add_modes_noedid() would remain the same.

> + }
>
> - count = drm_add_modes_noedid(connector,
> + if (!edid || count == 0) {
> + count = drm_add_modes_noedid(connector,
> connector->dev->mode_config.max_width,
> connector->dev->mode_config.max_height);
> - drm_set_preferred_mode(connector, 1024, 768);
> + drm_set_preferred_mode(connector, 1024, 768);
> + }
>
> + kfree(edid);
> return count;
> }
>
> @@ -77,10 +88,19 @@ static const struct drm_encoder_funcs hibmc_encoder_funcs = {
> int hibmc_vdac_init(struct hibmc_drm_private *priv)
> {
> struct drm_device *dev = priv->dev;
> + struct hibmc_connector *hibmc_connector = &priv->connector;
> struct drm_encoder *encoder = &priv->encoder;
> - struct drm_connector *connector = &priv->connector;
> + struct drm_connector *connector = &hibmc_connector->base;
> int ret;
>
> + hibmc_connector->dev = dev;

As mentioned, this dev field should be removed.

> +
> + ret = hibmc_ddc_create(hibmc_connector);
> + if (ret) {
> + drm_err(dev, "failed to create connector: %d\n", ret);

The error message appears to be incorrect. (?)

> + return ret;
> + }
> +
> encoder->possible_crtcs = 0x1;
> ret = drm_encoder_init(dev, encoder, &hibmc_encoder_funcs,
> DRM_MODE_ENCODER_DAC, NULL);
> @@ -91,12 +111,15 @@ int hibmc_vdac_init(struct hibmc_drm_private *priv)
>
> drm_encoder_helper_add(encoder, &hibmc_encoder_helper_funcs);
>
> - ret = drm_connector_init(dev, connector, &hibmc_connector_funcs,
> - DRM_MODE_CONNECTOR_VGA);
> + ret = drm_connector_init_with_ddc(dev, connector,
> + &hibmc_connector_funcs,
> + DRM_MODE_CONNECTOR_VGA,
> + &hibmc_connector->adapter);
> if (ret) {
> drm_err(dev, "failed to init connector: %d\n", ret);
> return ret;
> }
> +
> drm_connector_helper_add(connector, &hibmc_connector_helper_funcs);
>
> drm_connector_attach_encoder(connector, encoder);
>

--
Thomas Zimmermann
Graphics Driver Developer
SUSE Software Solutions Germany GmbH
Maxfeldstr. 5, 90409 Nürnberg, Germany
(HRB 36809, AG Nürnberg)
Geschäftsführer: Felix Imendörffer

[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2020-09-21 09:26    [W:0.436 / U:0.224 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site