lkml.org 
[lkml]   [2020]   [Sep]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH v3 06/11] kvm: arm64: Add helpers for accessing nVHE hyp per-cpu vars
On Wed, Sep 16, 2020 at 06:34:34PM +0100, David Brazdil wrote:
> Defining a per-CPU variable in hyp/nvhe will result in its name being
> prefixed with __kvm_nvhe_. Add helpers for declaring these variables
> in kernel proper and accessing them with this_cpu_ptr and per_cpu_ptr.
>
> Signed-off-by: David Brazdil <dbrazdil@google.com>
> ---
> arch/arm64/include/asm/kvm_asm.h | 25 +++++++++++++++++++++++--
> 1 file changed, 23 insertions(+), 2 deletions(-)
>
> diff --git a/arch/arm64/include/asm/kvm_asm.h b/arch/arm64/include/asm/kvm_asm.h
> index cf9456663289..abc03f386b40 100644
> --- a/arch/arm64/include/asm/kvm_asm.h
> +++ b/arch/arm64/include/asm/kvm_asm.h
> @@ -54,9 +54,21 @@
> DECLARE_KVM_VHE_SYM(sym); \
> DECLARE_KVM_NVHE_SYM(sym)
>
> +#define DECLARE_KVM_VHE_PER_CPU(type, sym) \
> + DECLARE_PER_CPU(type, sym)
> +#define DECLARE_KVM_NVHE_PER_CPU(type, sym) \
> + DECLARE_PER_CPU(type, kvm_nvhe_sym(sym))
> +
> +#define DECLARE_KVM_HYP_PER_CPU(type, sym) \
> + DECLARE_KVM_VHE_PER_CPU(type, sym); \
> + DECLARE_KVM_NVHE_PER_CPU(type, sym)
> +
> #define CHOOSE_VHE_SYM(sym) sym
> #define CHOOSE_NVHE_SYM(sym) kvm_nvhe_sym(sym)
>
> +#define this_cpu_ptr_nvhe(sym) this_cpu_ptr(&kvm_nvhe_sym(sym))
> +#define per_cpu_ptr_nvhe(sym, cpu) per_cpu_ptr(&kvm_nvhe_sym(sym), cpu)

nit: I'd probably stick a _sym suffix on these macros, to make it clear
that they're just munging the symbol name rather than doing some completely
different pcpu implementation.

THat said, do you expect these to be used outside of the pcpu
implementation? If not, I suggest some underscores as a prefix as well.

> #ifndef __KVM_NVHE_HYPERVISOR__
> /*
> * BIG FAT WARNINGS:
> @@ -69,12 +81,21 @@
> * - Don't let the nVHE hypervisor have access to this, as it will
> * pick the *wrong* symbol (yes, it runs at EL2...).
> */
> -#define CHOOSE_HYP_SYM(sym) (is_kernel_in_hyp_mode() ? CHOOSE_VHE_SYM(sym) \
> +#define CHOOSE_HYP_SYM(sym) (is_kernel_in_hyp_mode() \
> + ? CHOOSE_VHE_SYM(sym) \
> : CHOOSE_NVHE_SYM(sym))
> +#define this_cpu_ptr_hyp(sym) (is_kernel_in_hyp_mode() \
> + ? this_cpu_ptr(&sym) \
> + : this_cpu_ptr_nvhe(sym))
> +#define per_cpu_ptr_hyp(sym, cpu) (is_kernel_in_hyp_mode() \
> + ? per_cpu_ptr(&sym, cpu) \
> + : per_cpu_ptr_nvhe(sym, cpu))

is_kernel_in_hyp_mode() reads a system register to determine the current
exception level, so this doesn't seem like something we should be doing
everytime here. Perhaps is_kernel_in_hyp_mode() should avoid read_sysreg()
and instead use a non-volatile asm to allow the result to be cached by
the compiler. Hmm.

But I think that can be tackled as a future patch, so with the naming nits
resolved:

Acked-by: Will Deacon <will@kernel.org>

Will

\
 
 \ /
  Last update: 2020-09-18 11:24    [W:0.180 / U:0.096 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site