lkml.org 
[lkml]   [2020]   [Sep]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH] serial: qcom_geni_serial: To correct QUP Version detection logic
On 2020-09-02 11:34, Greg Kroah-Hartman wrote:
> On Wed, Sep 02, 2020 at 11:26:51AM +0530, Paras Sharma wrote:
>> The current implementation reduces the sampling rate by half
>> if qup HW version is greater is than 2.5 by checking if the
>> geni SE major version is greater than 2 and geni SE minor version
>> is greater than 5.
>>
>> This implementation fails when the version is 3 or greater.
>>
>> Hence new implementation checks if version is greater than or equal
>> to 0x20050000 which would work for any future version.
>>
>> Signed-off-by: Paras Sharma <parashar@codeaurora.org>
>> ---
>> drivers/tty/serial/qcom_geni_serial.c | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> Is this a v2 patch? What changed from the first one?

This patch is in continuation of
https://patchwork.kernel.org/patch/11708805/ .
It should have been V3 , i will correct it in my next patch .
In the previous version ,i had added a new condition to separately check
if QUP se major version is greater than or equal to 3.
In this ,i replaced the older logic of separately checking major and
minor versions for 2.5 and 3 with value of Qup version 0x20050000 .
This checks for version greater than 2.5 directly.
This would reduce the logic and will work for any future versions.

>
>>
>> diff --git a/drivers/tty/serial/qcom_geni_serial.c
>> b/drivers/tty/serial/qcom_geni_serial.c
>> index f0b1b47..e18b431 100644
>> --- a/drivers/tty/serial/qcom_geni_serial.c
>> +++ b/drivers/tty/serial/qcom_geni_serial.c
>> @@ -1000,7 +1000,7 @@ static void qcom_geni_serial_set_termios(struct
>> uart_port *uport,
>> sampling_rate = UART_OVERSAMPLING;
>> /* Sampling rate is halved for IP versions >= 2.5 */
>> ver = geni_se_get_qup_hw_version(&port->se);
>> - if (GENI_SE_VERSION_MAJOR(ver) >= 2 && GENI_SE_VERSION_MINOR(ver) >=
>> 5)
>> + if (ver >= 0x20050000)
>
> That's an odd "magic value", can't you use the existing macros to
> define
> this somehow so it makes sense?

The stable tag is not required because the board supporting version >
3 is not in any of the previous kernel versions.
I will define a separate macro for this value in my next patch.

>
> thanks,
>
> greg k-h

\
 
 \ /
  Last update: 2020-09-10 08:25    [W:0.038 / U:0.468 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site